summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-06 16:13:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-06 16:22:28 +0100
commit3f2247adb5eee61c53c90a0f86adb7125f2559d8 (patch)
tree3198f682bb23f9f3425049b5c579957bb32af3e1 /dev-python/python-memcached
parentprofiles/updates: fix OldPackageUpdate (diff)
downloadgentoo-3f2247adb5eee61c53c90a0f86adb7125f2559d8.tar.gz
gentoo-3f2247adb5eee61c53c90a0f86adb7125f2559d8.tar.bz2
gentoo-3f2247adb5eee61c53c90a0f86adb7125f2559d8.zip
dev-python/python-memcached: Use unittest instead of nose
Closes: https://bugs.gentoo.org/888261 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-memcached')
-rw-r--r--dev-python/python-memcached/python-memcached-1.59-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-python/python-memcached/python-memcached-1.59-r1.ebuild b/dev-python/python-memcached/python-memcached-1.59-r1.ebuild
index b925997aac3d..8a90d01b36a7 100644
--- a/dev-python/python-memcached/python-memcached-1.59-r1.ebuild
+++ b/dev-python/python-memcached/python-memcached-1.59-r1.ebuild
@@ -27,23 +27,23 @@ BDEPEND="
)
"
-distutils_enable_tests nose
+distutils_enable_tests unittest
python_test() {
local pidfile="${TMPDIR}/memcached.pid"
- memcached -d -P "$pidfile" || die "failed to start memcached"
+ memcached -d -P "${pidfile}" || die "failed to start memcached"
- nosetests -v || die "Tests fail with ${EPYTHON}"
+ eunittest || die "Tests fail with ${EPYTHON}"
- kill "$(<"$pidfile")" || die "failed to kill memcached"
+ kill "$(<"${pidfile}")" || die "failed to kill memcached"
local elapsed=0
- while [[ -f "$pidfile" ]]; do
- if [[ $elapsed -ge 30 ]]; then
- kill -KILL "$(<"$pidfile")" || die "failed to kill -KILL memcached"
+ while [[ -f ${pidfile} ]]; do
+ if [[ $(( elapsed++ )) -ge 30 ]]; then
+ kill -KILL "$(<"${pidfile}")" ||
+ die "failed to kill -KILL memcached"
die "memcached failed to stop after 30 seconds"
fi
sleep 1
- let elapsed++
done
}