summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 12:07:52 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 13:19:21 +0100
commit99eaf7fb21765a3a7c16293348edc0ec69c03fa4 (patch)
tree6e0e37e4a0fb487fea83b18b701db0f842ecec5f /dev-python/python-levenshtein
parentdev-java/sbt: Thanks to _flow_ for reporting, upstream changed sbt-launch binary (diff)
downloadgentoo-99eaf7fb21765a3a7c16293348edc0ec69c03fa4.tar.gz
gentoo-99eaf7fb21765a3a7c16293348edc0ec69c03fa4.tar.bz2
gentoo-99eaf7fb21765a3a7c16293348edc0ec69c03fa4.zip
dev-python/python-levenshtein: properly build docs
Chop DESCRIPTION to 80 chars Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=574230 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/python-levenshtein')
-rw-r--r--dev-python/python-levenshtein/python-levenshtein-0.11.2.ebuild23
-rw-r--r--dev-python/python-levenshtein/python-levenshtein-0.12.0.ebuild24
2 files changed, 27 insertions, 20 deletions
diff --git a/dev-python/python-levenshtein/python-levenshtein-0.11.2.ebuild b/dev-python/python-levenshtein/python-levenshtein-0.11.2.ebuild
index ff974dabc022..186d26550d84 100644
--- a/dev-python/python-levenshtein/python-levenshtein-0.11.2.ebuild
+++ b/dev-python/python-levenshtein/python-levenshtein-0.11.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -10,8 +10,9 @@ inherit distutils-r1
MY_PN="python-Levenshtein"
MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Functions for fast computation of Levenshtein (edit) distance, and edit operations"
-HOMEPAGE="https://github.com/miohtama/python-Levenshtein/tree/
+DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
+HOMEPAGE="
+ https://github.com/miohtama/python-Levenshtein/tree/
https://pypi.python.org/pypi/python-Levenshtein/"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
@@ -20,20 +21,22 @@ SLOT="0"
KEYWORDS="amd64 ia64 x86"
IUSE="doc"
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*' pypy) ) )"
+
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' pypy )
+}
+
python_compile_all() {
if use doc; then
- # Cannot assume user has a system py2 or pypy
- if python_is_python3; then
- die "The build of Levenshtein.html is not supported by python3"
- else
- einfo "Generation of documentation"
- "${PYTHON}" "${FILESDIR}/genextdoc.py" Levenshtein || die "Generation of documentation failed"
- fi
+ einfo "Generation of documentation"
+ "${PYTHON}" "${FILESDIR}/genextdoc.py" Levenshtein \
+ || die "Generation of documentation failed"
fi
}
diff --git a/dev-python/python-levenshtein/python-levenshtein-0.12.0.ebuild b/dev-python/python-levenshtein/python-levenshtein-0.12.0.ebuild
index d25b40f3bf45..e87849472c83 100644
--- a/dev-python/python-levenshtein/python-levenshtein-0.12.0.ebuild
+++ b/dev-python/python-levenshtein/python-levenshtein-0.12.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
@@ -10,8 +11,9 @@ inherit distutils-r1
MY_PN="python-Levenshtein"
MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Functions for fast computation of Levenshtein (edit) distance, and edit operations"
-HOMEPAGE="https://github.com/miohtama/python-Levenshtein/tree/
+DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
+HOMEPAGE="
+ https://github.com/miohtama/python-Levenshtein/tree/
https://pypi.python.org/pypi/python-Levenshtein/"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
@@ -20,20 +22,22 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~x86"
IUSE="doc"
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*' pypy) ) )"
+
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' pypy )
+}
+
python_compile_all() {
if use doc; then
- # Cannot assume user has a system py2 or pypy
- if python_is_python3; then
- die "The build of Levenshtein.html is not supported by python3"
- else
- einfo "Generation of documentation"
- "${PYTHON}" "${FILESDIR}/genextdoc.py" Levenshtein || die "Generation of documentation failed"
- fi
+ einfo "Generation of documentation"
+ "${PYTHON}" "${FILESDIR}/genextdoc.py" Levenshtein \
+ || die "Generation of documentation failed"
fi
}