summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-04 04:46:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-04 05:12:22 +0200
commit031fcff8a1b1e32ff7ce82df1c3933f5d3fce54b (patch)
tree83b044fba04d3ae86a0c8ecaef7c6f0e90578db1 /dev-python/python-dbusmock
parentdev-python/mkdocs-pymdownx-material-extras: Bump to 2.6 (diff)
downloadgentoo-031fcff8a1b1e32ff7ce82df1c3933f5d3fce54b.tar.gz
gentoo-031fcff8a1b1e32ff7ce82df1c3933f5d3fce54b.tar.bz2
gentoo-031fcff8a1b1e32ff7ce82df1c3933f5d3fce54b.zip
dev-python/python-dbusmock: Bump to 0.32.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest1
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.32.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 1ed2114e3802..57d62953fb4a 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1 +1,2 @@
DIST python-dbusmock-0.32.1.tar.gz 104265 BLAKE2B 78357a767e8f008463c69b55b57a02016c1aa1a392dc7a1ef3392020af839ef553ed6ff3cadac12a9c175efccdb29c7f3ed74ab7abafb0436a760dbe3193fbc6 SHA512 14b71c5d0a760fd1e8609815e4ae702ebc5c9f1f3c3e1bd930da616350b63b7fdbf99c7d584f5a834857798fb1cad56347d6a1cf2bdd758f9100180b0a7e725d
+DIST python-dbusmock-0.32.2.tar.gz 104818 BLAKE2B c0859d38efe9e78f465c5e69980ada2a0309fc654a4a77f213b23e4140d7fad60f497d9a0004c61db1870eaeb3700a5ee46ce2f14b4e570cb3c74ede99c24980 SHA512 09981dddd49e430093996de78d96293c46867fad7ab24e1badde25cda5f60b05324bd203d5738e8f4315c5744809876ac4afd73aa26bcc6afa05fd631c03ceba
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.32.2.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.32.2.ebuild
new file mode 100644
index 000000000000..eafbf2454b72
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.32.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ sys-power/upower
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # tests are fragile to long socket paths
+ local -x TMPDIR=/tmp
+ # Tests break if XDG_DATA_DIRS is modified by flatpak install
+ unset XDG_DATA_DIRS
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}