summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-05-12 16:20:32 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-05-12 17:04:07 -0400
commit9d4dc67581ba2bb85fbea34ddc7e976688e30907 (patch)
tree73d8dee9d3591b18f8d8cbbddcdb61eb87d67aac /dev-python/python-caja
parentmate-extra/caja-dropbox: bump to 1.22.1 (diff)
downloadgentoo-9d4dc67581ba2bb85fbea34ddc7e976688e30907.tar.gz
gentoo-9d4dc67581ba2bb85fbea34ddc7e976688e30907.tar.bz2
gentoo-9d4dc67581ba2bb85fbea34ddc7e976688e30907.zip
dev-python/python-caja: fix extension directory
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'dev-python/python-caja')
-rw-r--r--dev-python/python-caja/python-caja-1.22.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-caja/python-caja-1.22.0-r1.ebuild b/dev-python/python-caja/python-caja-1.22.0-r1.ebuild
new file mode 100644
index 000000000000..2b856fe5ad92
--- /dev/null
+++ b/dev-python/python-caja/python-caja-1.22.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Python bindings for the Caja file manager"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="doc"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.50:2
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=mate-base/caja-1.17.1[introspection]
+ >=x11-libs/gtk+-3.22:3"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ virtual/pkgconfig:*
+ doc? ( app-text/docbook-xml-dtd:4.1.2 )"
+
+src_install() {
+ mate_src_install
+
+ # Keep the directory for systemwide extensions.
+ keepdir /usr/share/caja-python/extensions/
+
+ # The HTML documentation generation is broken and commented out by upstream.
+ #
+ #if use doc ; then
+ # insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+ # doins -r docs/html/*
+ #fi
+}