summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-10 09:10:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-10 09:13:15 +0200
commit64c5cbea6a1bad9d1de472fad6a0dcc9f044548b (patch)
treec380f06e3630ef1707ac4991bcd8c1673160b7f6 /dev-python/pytest-timeout
parentmedia-libs/opencv: Stabilize 4.8.0-r1 amd64, #915427 (diff)
downloadgentoo-64c5cbea6a1bad9d1de472fad6a0dcc9f044548b.tar.gz
gentoo-64c5cbea6a1bad9d1de472fad6a0dcc9f044548b.tar.bz2
gentoo-64c5cbea6a1bad9d1de472fad6a0dcc9f044548b.zip
dev-python/pytest-timeout: Enable xdist
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild
index 0201b80b5b46..d099aaa62e42 100644
--- a/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild
+++ b/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{10..12} pypy3 )
-inherit distutils-r1 pypi
+inherit distutils-r1 multiprocessing pypi
DESCRIPTION="pytest plugin to abort hanging tests"
HOMEPAGE="
@@ -24,6 +24,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~
BDEPEND="
test? (
dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
!hppa? (
$(python_gen_cond_dep '
dev-python/pytest-cov[${PYTHON_USEDEP}]
@@ -34,8 +35,12 @@ BDEPEND="
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
- # TODO
- test_pytest_timeout.py::test_suppresses_timeout_when_debugger_is_entered
- test_pytest_timeout.py::test_disable_debugger_detection_flag
-)
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test_pytest_timeout.py::test_suppresses_timeout_when_debugger_is_entered
+ test_pytest_timeout.py::test_disable_debugger_detection_flag
+ )
+
+ epytest -n "$(makeopts_jobs)" --dist=worksteal
+}