summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-06 17:03:24 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-06 17:07:42 +0200
commitd4d4afca492cce112a620e46cc8cee8979096eb4 (patch)
tree924a7af76dd2ab903a572f464a16a58658728bf1 /dev-python/pytest-regressions
parentdev-python/jaraco-logging: Remove old (diff)
downloadgentoo-d4d4afca492cce112a620e46cc8cee8979096eb4.tar.gz
gentoo-d4d4afca492cce112a620e46cc8cee8979096eb4.tar.bz2
gentoo-d4d4afca492cce112a620e46cc8cee8979096eb4.zip
dev-python/pytest-regressions: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-regressions')
-rw-r--r--dev-python/pytest-regressions/Manifest2
-rw-r--r--dev-python/pytest-regressions/pytest-regressions-2.4.2.ebuild62
-rw-r--r--dev-python/pytest-regressions/pytest-regressions-2.4.3.ebuild62
3 files changed, 0 insertions, 126 deletions
diff --git a/dev-python/pytest-regressions/Manifest b/dev-python/pytest-regressions/Manifest
index ff5051faff4a..48301dffe964 100644
--- a/dev-python/pytest-regressions/Manifest
+++ b/dev-python/pytest-regressions/Manifest
@@ -1,3 +1 @@
-DIST pytest-regressions-2.4.2.tar.gz 111030 BLAKE2B 4c1d3ce9a210b6156e046b91688aec6ecab53d4719b5b556cdf6773a6af891352f7f213259140fdb7234f2528dbad5bf5c4ed43431aee94bfd373dd1839c1231 SHA512 f5abcc09da7a466e446329737d4926d3c7c9ac274e1087e6f746fe263b4cfd1b0f4b8870eea3d22b1209a0d5ead7b7169e700d10f3f29bb978e12a33511b1f51
-DIST pytest-regressions-2.4.3.tar.gz 111049 BLAKE2B a9b11ec715c49f63c5972bad6332715b22efd363c70f067c4c077ae0e9af64178edb98aa36cd4d24287db4b2705367c18c09795b7830a09e2007c7da8a078964 SHA512 4264e2d791f6235b5de57a45550f8d0d0a6d3f7f10b40095698670daa8848005bc44c3cb2c11d793b58eb8b27e3910042c63fd4c0bd573ed57615d570e9e7d8b
DIST pytest-regressions-2.5.0.tar.gz 113615 BLAKE2B 3364893a9cd96a44611d023c08fe5e319ceaad5a6a9b210b72095a560c42742c871406de1290821ea5cd61960bf5bef72d08bd143db93b20f288d5367cf1ae70 SHA512 2d23568b8d5dbc86000c9b552c72a1e269fafe79e0b829f799fe31ecc142e74d233c69940a51d2da457c6f7b3713fcd788461b0420eca9d56cc395568c517c0f
diff --git a/dev-python/pytest-regressions/pytest-regressions-2.4.2.ebuild b/dev-python/pytest-regressions/pytest-regressions-2.4.2.ebuild
deleted file mode 100644
index 134c2a769390..000000000000
--- a/dev-python/pytest-regressions/pytest-regressions-2.4.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Easy to use fixtures to write regression tests"
-HOMEPAGE="
- https://github.com/ESSS/pytest-regressions/
- https://pypi.org/project/pytest-regressions/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-datadir[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/sphinx-rtd-theme
-
-python_test() {
- local EPYTEST_DESELECT=()
- local EPYTEST_IGNORE=()
- if ! has_version "dev-python/matplotlib[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/test_image_regression.py::test_image_regression
- )
- fi
- if ! has_version "dev-python/numpy[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=(
- tests/test_ndarrays_regression.py
- )
- fi
- if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/test_filenames.py::test_foo
- tests/test_filenames.py::TestClass::test_foo
- tests/test_filenames.py::TestClassWithIgnoredName::test_foo
- )
- EPYTEST_IGNORE+=(
- tests/test_dataframe_regression.py
- tests/test_num_regression.py
- )
- fi
- if ! has_version "dev-python/pillow[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/test_image_regression.py
- )
- fi
-
- epytest
-}
diff --git a/dev-python/pytest-regressions/pytest-regressions-2.4.3.ebuild b/dev-python/pytest-regressions/pytest-regressions-2.4.3.ebuild
deleted file mode 100644
index 2656b1b8d726..000000000000
--- a/dev-python/pytest-regressions/pytest-regressions-2.4.3.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Easy to use fixtures to write regression tests"
-HOMEPAGE="
- https://github.com/ESSS/pytest-regressions/
- https://pypi.org/project/pytest-regressions/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-datadir[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/sphinx-rtd-theme
-
-python_test() {
- local EPYTEST_DESELECT=()
- local EPYTEST_IGNORE=()
- if ! has_version "dev-python/matplotlib[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/test_image_regression.py::test_image_regression
- )
- fi
- if ! has_version "dev-python/numpy[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=(
- tests/test_ndarrays_regression.py
- )
- fi
- if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/test_filenames.py::test_foo
- tests/test_filenames.py::TestClass::test_foo
- tests/test_filenames.py::TestClassWithIgnoredName::test_foo
- )
- EPYTEST_IGNORE+=(
- tests/test_dataframe_regression.py
- tests/test_num_regression.py
- )
- fi
- if ! has_version "dev-python/pillow[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/test_image_regression.py
- )
- fi
-
- epytest
-}