summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-24 06:08:32 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-24 06:08:32 +0100
commit71ecdfe02063d43c31aedf3544cc0c2777127d06 (patch)
treeef8412f0ac6c1cb537cdc7b4fcaa5254ddf77ada /dev-python/pytest-param-files/pytest-param-files-0.3.5.ebuild
parentapp-admin/awscli: Bump to 1.27.78 (diff)
downloadgentoo-71ecdfe02063d43c31aedf3544cc0c2777127d06.tar.gz
gentoo-71ecdfe02063d43c31aedf3544cc0c2777127d06.tar.bz2
gentoo-71ecdfe02063d43c31aedf3544cc0c2777127d06.zip
dev-python/pytest-param-files: Bump to 0.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-param-files/pytest-param-files-0.3.5.ebuild')
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.3.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.3.5.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.3.5.ebuild
new file mode 100644
index 000000000000..06df570c3e27
--- /dev/null
+++ b/dev-python/pytest-param-files/pytest-param-files-0.3.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest parametrize decorators from external files."
+HOMEPAGE="
+ https://github.com/chrisjsewell/pytest-param-files/
+ https://pypi.org/project/pytest_param_files/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest