summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 19:40:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 19:54:47 +0200
commitb72d0875fd91ff39d1eff1c386a5bfa2f72e29de (patch)
treec02fb50893abefc952c2172eca1d50353560b18f /dev-python/pytest-expect
parentdev-python/u-msgpack-python: Enable py3.11 (diff)
downloadgentoo-b72d0875fd91ff39d1eff1c386a5bfa2f72e29de.tar.gz
gentoo-b72d0875fd91ff39d1eff1c386a5bfa2f72e29de.tar.bz2
gentoo-b72d0875fd91ff39d1eff1c386a5bfa2f72e29de.zip
dev-python/pytest-expect: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-expect')
-rw-r--r--dev-python/pytest-expect/pytest-expect-1.1.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-expect/pytest-expect-1.1.0-r2.ebuild b/dev-python/pytest-expect/pytest-expect-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..ffa30e75d716
--- /dev/null
+++ b/dev-python/pytest-expect/pytest-expect-1.1.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin that stores test expectations by saving the set of failing tests"
+HOMEPAGE="
+ https://github.com/gsnedders/pytest-expect/
+ https://pypi.org/project/pytest-expect/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+# no tests
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/u-msgpack-python[${PYTHON_USEDEP}]
+"