summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-27 21:05:59 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-27 21:09:44 +0100
commitd49fc3d2564b100ca39376fa94a206bf3d7abc91 (patch)
treedacef95344bd16507698830d5a50ea52143da93f /dev-python/pyside6-tools
parentdev-python/pyside6: Remove old (diff)
downloadgentoo-d49fc3d2564b100ca39376fa94a206bf3d7abc91.tar.gz
gentoo-d49fc3d2564b100ca39376fa94a206bf3d7abc91.tar.bz2
gentoo-d49fc3d2564b100ca39376fa94a206bf3d7abc91.zip
dev-python/pyside6-tools: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyside6-tools')
-rw-r--r--dev-python/pyside6-tools/Manifest2
-rw-r--r--dev-python/pyside6-tools/pyside6-tools-6.4.0.ebuild64
-rw-r--r--dev-python/pyside6-tools/pyside6-tools-6.4.1.ebuild64
3 files changed, 0 insertions, 130 deletions
diff --git a/dev-python/pyside6-tools/Manifest b/dev-python/pyside6-tools/Manifest
index 05fa7cc67441..1f656317eec9 100644
--- a/dev-python/pyside6-tools/Manifest
+++ b/dev-python/pyside6-tools/Manifest
@@ -1,3 +1 @@
-DIST pyside-setup-opensource-src-6.4.0.tar.xz 8551772 BLAKE2B 180d9f2182b8df04394677bbcb0765764d9de1f34064fc688a3ccae8ec37174b4a01fa70c80d98c7ca7fe6b45239225bd801c552d332e2c6fc4a3726535e72e9 SHA512 0517408f110830b888f04777c60b29479831604877da13c5a41a710888ebe53064f06d9b7b61d5c6e6a483ac5ee1639a63bb7f9844301df53e3e9ca8eafcf9e9
-DIST pyside-setup-opensource-src-6.4.1.tar.xz 8755436 BLAKE2B 9b88115374eb690282397fbf33fa6698043c77c8defd40fd0d711dee39aa4cd56af94533cf1703b87084e8755758fe636b877071a29043ee7f4c8e406e47cf38 SHA512 330eef5d63c5225e0d3ee8be1229e81ac04ec39772766fd2dfe197291a8153c00a2cd548ce6e49a0a198b3081535c79a7e649a6e9f03dfe67df68790543ea023
DIST pyside-setup-opensource-src-6.4.2.tar.xz 8759528 BLAKE2B cc1a18e9dc81eb02bbfffd38816da68f053337f94c485fdd2f99488ae7ade2e899be1d98518def8f39a4eeaeaff6018ff09402bfe55b3484d78d8c4d9796b4e7 SHA512 129ea420000fceef9726fab9e0320e8286a34aa0855fc4bd369adc0020b76909b3a5ac8c3fa622b73da1561b39dcaeb8ac121f634918e2c0460a9ebaccb0f659
diff --git a/dev-python/pyside6-tools/pyside6-tools-6.4.0.ebuild b/dev-python/pyside6-tools/pyside6-tools-6.4.0.ebuild
deleted file mode 100644
index 3b91041b8b88..000000000000
--- a/dev-python/pyside6-tools/pyside6-tools-6.4.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# TODO: Add PyPy once officially supported. See also:
-# https://bugreports.qt.io/browse/PYSIDE-535
-PYTHON_COMPAT=( python3_{9..11} )
-CMAKE_IN_SOURCE_BUILD=1
-
-inherit cmake python-r1
-
-MY_P=pyside-setup-opensource-src-${PV}
-
-DESCRIPTION="PySide development tools (pyside6-lupdate with support for Python)"
-HOMEPAGE="https://wiki.qt.io/PySide6"
-SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-${PV}-src/${MY_P}.tar.xz"
-S="${WORKDIR}/${MY_P}/sources/pyside-tools"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- ~dev-python/pyside6-${PV}[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- cmake_src_prepare
-
- python_copy_sources
-}
-
-src_configure() {
- pyside-tools_configure() {
- local mycmakeargs=(
- # the tools conflict with tools from Qt
- -DNO_QT_TOOLS=yes
- )
- CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_configure
- }
-
- python_foreach_impl pyside-tools_configure
-}
-
-src_compile() {
- pyside-tools_compile() {
- CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_compile
- }
-
- python_foreach_impl pyside-tools_compile
-}
-
-src_install() {
- pyside-tools_install() {
- python_doexe "${BUILD_DIR}/"*.py
- }
-
- python_foreach_impl pyside-tools_install
-
- einstalldocs
-}
diff --git a/dev-python/pyside6-tools/pyside6-tools-6.4.1.ebuild b/dev-python/pyside6-tools/pyside6-tools-6.4.1.ebuild
deleted file mode 100644
index 3b91041b8b88..000000000000
--- a/dev-python/pyside6-tools/pyside6-tools-6.4.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# TODO: Add PyPy once officially supported. See also:
-# https://bugreports.qt.io/browse/PYSIDE-535
-PYTHON_COMPAT=( python3_{9..11} )
-CMAKE_IN_SOURCE_BUILD=1
-
-inherit cmake python-r1
-
-MY_P=pyside-setup-opensource-src-${PV}
-
-DESCRIPTION="PySide development tools (pyside6-lupdate with support for Python)"
-HOMEPAGE="https://wiki.qt.io/PySide6"
-SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-${PV}-src/${MY_P}.tar.xz"
-S="${WORKDIR}/${MY_P}/sources/pyside-tools"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- ~dev-python/pyside6-${PV}[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- cmake_src_prepare
-
- python_copy_sources
-}
-
-src_configure() {
- pyside-tools_configure() {
- local mycmakeargs=(
- # the tools conflict with tools from Qt
- -DNO_QT_TOOLS=yes
- )
- CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_configure
- }
-
- python_foreach_impl pyside-tools_configure
-}
-
-src_compile() {
- pyside-tools_compile() {
- CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_compile
- }
-
- python_foreach_impl pyside-tools_compile
-}
-
-src_install() {
- pyside-tools_install() {
- python_doexe "${BUILD_DIR}/"*.py
- }
-
- python_foreach_impl pyside-tools_install
-
- einstalldocs
-}