summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pypcap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pypcap')
-rw-r--r--dev-python/pypcap/Manifest2
-rw-r--r--dev-python/pypcap/metadata.xml10
-rw-r--r--dev-python/pypcap/pypcap-1.1.1.ebuild27
-rw-r--r--dev-python/pypcap/pypcap-1.1.3.ebuild27
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pypcap/Manifest b/dev-python/pypcap/Manifest
new file mode 100644
index 000000000000..edf7d76bcb59
--- /dev/null
+++ b/dev-python/pypcap/Manifest
@@ -0,0 +1,2 @@
+DIST pypcap-1.1.1.tar.gz 44878 SHA256 b310d5af36f5d68ef4217fda68086ffce56345b415eaac15ad618f94057b017b SHA512 339a081cc06edc2f532b7a8eb962b3fd1d1185ed4fb42ef4a3b768bb27d852a7878d4e08ca421b0fdabd6db61b53663fbf20a073fa61f1839e06bdaf13ec1060 WHIRLPOOL 52cabe0b91747657a1f923ee619771d56af1c544ae7635f1e7e7dc0030064b8edcfe8ef9dc604163b85dce89b79b75e5595736863255147af7e34a2d7070821c
+DIST pypcap-1.1.3.tar.gz 44805 SHA256 cc0786efd527f16c5f0d08accf3cbd9ff8971ddc284a445cdabf2e47b458a377 SHA512 c8c3634173246838cd1d716ffd630cc149daa171749ab22901b352ed98f58c1377a754bf8510c33dc338deec4c80e5462eaf8baec502f1edb79cfac3ab8844bc WHIRLPOOL 2354f992aace04acad55e2dd8563543d5b4a408734259c228b6f3e30be587248e6db228b87b76c78e7e78b8a7007e4411684e8822dc9d0c3768df9a6ff07bcbc
diff --git a/dev-python/pypcap/metadata.xml b/dev-python/pypcap/metadata.xml
new file mode 100644
index 000000000000..1b65681c8e3b
--- /dev/null
+++ b/dev-python/pypcap/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="google-code">pypcap</remote-id>
+ <remote-id type="pypi">pypcap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pypcap/pypcap-1.1.1.ebuild b/dev-python/pypcap/pypcap-1.1.1.ebuild
new file mode 100644
index 000000000000..ffcb66237c19
--- /dev/null
+++ b/dev-python/pypcap/pypcap-1.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplified object-oriented Python extension module for libpcap"
+HOMEPAGE="http://code.google.com/p/pypcap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
diff --git a/dev-python/pypcap/pypcap-1.1.3.ebuild b/dev-python/pypcap/pypcap-1.1.3.ebuild
new file mode 100644
index 000000000000..121ce6ce3bfb
--- /dev/null
+++ b/dev-python/pypcap/pypcap-1.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplified object-oriented Python extension module for libpcap"
+HOMEPAGE="http://code.google.com/p/pypcap/ https://pypi.python.org/pypi/pypcap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}