summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-18 12:36:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-18 12:36:39 +0100
commit485983cc2fbac5bb1798f76ef2ee90c002d98477 (patch)
treef83a65286d222f49000c00b6bcc1a8f26701fa6f /dev-python/pypax
parentdev-python/pylibmc: Remove old (diff)
downloadgentoo-485983cc2fbac5bb1798f76ef2ee90c002d98477.tar.gz
gentoo-485983cc2fbac5bb1798f76ef2ee90c002d98477.tar.bz2
gentoo-485983cc2fbac5bb1798f76ef2ee90c002d98477.zip
dev-python/pypax: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypax')
-rw-r--r--dev-python/pypax/pypax-0.9.5.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/pypax/pypax-0.9.5.ebuild b/dev-python/pypax/pypax-0.9.5.ebuild
deleted file mode 100644
index 61c08aa64aae..000000000000
--- a/dev-python/pypax/pypax-0.9.5.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{8,9} )
-
-inherit distutils-r1
-
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
- inherit git-r3
-else
- SRC_URI="https://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
- S="${WORKDIR}/elfix-${PV}"
-fi
-
-DESCRIPTION="Python module to get or set either PT_PAX and/or XATTR_PAX flags"
-HOMEPAGE="https://dev.gentoo.org/~blueness/elfix/
- https://wiki.gentoo.org/wiki/Project:Hardened/PaX_Quickstart"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+ptpax +xtpax"
-
-REQUIRED_USE="|| ( ptpax xtpax )"
-
-RDEPEND="
- ptpax? ( dev-libs/elfutils )
- xtpax? ( sys-apps/attr )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${RDEPEND}"
-
-src_compile() {
- cd scripts || die
- unset PTPAX
- unset XTPAX
- use ptpax && export PTPAX="yes"
- use xtpax && export XTPAX="yes"
- distutils-r1_src_compile
-}
-
-src_install() {
- cd scripts || die
- distutils-r1_src_install
-}