summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-06-09 19:09:11 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-06-09 19:09:11 +0200
commitf50c230499a3fe5875f3fe726a3453747abdf88e (patch)
treef77660d303c491229bec8c78e38c24d576ae196b /dev-python/pymysql
parentsys-devel/autoconf-archive: x86 stable, applying ALLARCHES policy (diff)
downloadgentoo-f50c230499a3fe5875f3fe726a3453747abdf88e.tar.gz
gentoo-f50c230499a3fe5875f3fe726a3453747abdf88e.tar.bz2
gentoo-f50c230499a3fe5875f3fe726a3453747abdf88e.zip
dev-python/pymysql: bump to v0.8.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/pymysql')
-rw-r--r--dev-python/pymysql/Manifest1
-rw-r--r--dev-python/pymysql/pymysql-0.8.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pymysql/Manifest b/dev-python/pymysql/Manifest
index fa5aa52be681..19819261306d 100644
--- a/dev-python/pymysql/Manifest
+++ b/dev-python/pymysql/Manifest
@@ -1,2 +1,3 @@
DIST pymysql-0.7.11.tar.gz 82213 BLAKE2B 45ef3b4c8f4d9a9d3cb5b706f68a52b860bc21298b9fb7d983ea3fc6910c5a53e9e963a712735f93588501ff7297a2f10a74b44965eab4554a554a4a9f0e2b0e SHA512 b83fbbf77fad8e775ba48cf56f32deb61d2d54d64bd1f83e097c61d87b33a881787125c839b78f18b413722299c24a8a14dc9b36f5df7ff7f9c6ea56b2597150
DIST pymysql-0.8.0.tar.gz 82975 BLAKE2B c1345ff6d266d5a3670d8bb1d7d7becad218ed294ab912f3f28e49163851e2e36fc1bb5a13a5d0f62ba753d264f736a6a87e11d290cc4fd604714fe1d4f9569d SHA512 41597d3955a35283656b5cbc137b0cb63eb48658dc61f0ba1fc0c207bad07472896e557b2996e52fbc2646163bce69e7d2fed81349355e72368cf395f51e2916
+DIST pymysql-0.8.1.tar.gz 83887 BLAKE2B 0181970d714d45db644636b57105bba1ea8d8d3ded537555ab1ae5afdc0cad308dbdfe6a67c50905ba1a2ea8cd5302bac8f997f64f0b6874436e4b90a3ea8a78 SHA512 0a58bb6a74281aaec5d23c4e59407ff1d7f3fd379285a21a39f14ad18008303d79aa87b99ebfe2536775f8b369875b15907ae6653d038a2d44589cf47ac0a2b9
diff --git a/dev-python/pymysql/pymysql-0.8.1.ebuild b/dev-python/pymysql/pymysql-0.8.1.ebuild
new file mode 100644
index 000000000000..69f4ea52edf5
--- /dev/null
+++ b/dev-python/pymysql/pymysql-0.8.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="PyMySQL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pure-Python MySQL Driver"
+HOMEPAGE="https://github.com/PyMySQL/PyMySQL"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# While tests exist, they require an unsecure server to run without manual config file
+RESTRICT="test"
+
+python_test() {
+ ${PYTHON} runtests.py || die
+}