summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-02 17:17:16 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-02 17:21:36 -0700
commit894c243f616c899c57f93483a03b7bd90ed60daf (patch)
treec7752be79e2cc1c4da407e3e2a68d68a3263435e /dev-python/pympler
parentdev-perl/Net-SSH-Perl: -r1 bump for RDEP propagation (diff)
downloadgentoo-894c243f616c899c57f93483a03b7bd90ed60daf.tar.gz
gentoo-894c243f616c899c57f93483a03b7bd90ed60daf.tar.bz2
gentoo-894c243f616c899c57f93483a03b7bd90ed60daf.zip
dev-python/pympler: version bump to 0.4.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/pympler')
-rw-r--r--dev-python/pympler/Manifest1
-rw-r--r--dev-python/pympler/pympler-0.4.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pympler/Manifest b/dev-python/pympler/Manifest
index cd57e12d3b02..e669fc745620 100644
--- a/dev-python/pympler/Manifest
+++ b/dev-python/pympler/Manifest
@@ -1,2 +1,3 @@
DIST Pympler-0.4.1.tar.gz 395535 SHA256 6a8bfd2972c4ec34ac8750358515950be4a4ca13dfa6a05a9a22419786745f90 SHA512 3f7e2d88ca431ae73cf49d5140c10de4eab10c1627cdacc12e216c89410add16cb5e1faedc484ea765e4b866b905a5379bb21e7d41b9b8d622c4ac7b1b16a8a3 WHIRLPOOL 4b35b554cabda8b9ab633409f1c91728956cad31c1a41d3b66a8d2cbf2e1283edd32017181d5f9c8bd66a1bac7ba398c292dd60fd9cdc268fec86222b4a790c8
DIST Pympler-0.4.2.tar.gz 395765 SHA256 3c3f9d8eb3dddf4f29c433433ea77c9c3f2f0dcc06575c0c2a9d81b2602893b2 SHA512 ae6e7718ecf8e7bc46ce968dd3b57543c4a3e882a07d7cb68ee38e60debc157ce2410c66b23c14179c47fef1b89647886289d9e4fdfc5f9e9ecd87a052f204aa WHIRLPOOL cc1e0ddb1509d92f3cc44f8e09c84a4fdc59fb273d0d5c2e10c421c97d0b83468dd7ffbf8d9817a480683afefb0f7dcf79993aa4ec7a7fb6b1789fc655ecb9c6
+DIST pympler-0.4.3.tar.gz 259409 SHA256 80dfbda9c9dc36d8cc6696b9f1066d4c6bdb87371f58fe7940fad8918b8c288f SHA512 de4a36e8e5b639c1b78460677d821a5ad829c01a568496a5df4682ab32fea14e24c47260aed96c68722285e3fdb4b202348a7cbfcb95531ca2954bd8d5cebb68 WHIRLPOOL 21324bd5b30be363e4295e6191aa2bc884b97b4224623c019fe888f394bc5bca59391f69503fbb0c799f3e93b68f6920728843197a0fd8680ac975ec4b6234e4
diff --git a/dev-python/pympler/pympler-0.4.3.ebuild b/dev-python/pympler/pympler-0.4.3.ebuild
new file mode 100644
index 000000000000..bac8394e16ce
--- /dev/null
+++ b/dev-python/pympler/pympler-0.4.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="Pympler"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Memory profiling for Python applications"
+HOMEPAGE="https://code.google.com/p/pympler/ https://pypi.python.org/pypi/Pympler https://github.com/pympler/pympler"
+SRC_URI="https://github.com/pympler/pympler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# The PyPi tarball is missing the documentation
+#SRC_URI="mirror://pypi/P/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/bottle[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ rm pympler/util/bottle.py || die
+ sed \
+ -e '/import bottle/s:^.*$:import bottle:g' \
+ -i pympler/web.py || die
+ # test_flatsize and AsizeofTest always fail
+ sed '14,106d' -i test/asizeof/test_asizeof.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ sphinx-build -b html doc/{source,html} || die
+ fi
+}
+
+python_test() {
+ # https://github.com/pympler/pympler/issues/22
+ esetup.py try
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}