summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2022-03-26 15:15:24 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-04-01 20:22:13 +0200
commit83b8d8e174d2c106a6a6fb583846acb91c1d88c2 (patch)
tree7ba93dba8a68924c2616185d727602e0c5103f1f /dev-python/pylatex
parentdev-python/pylatex: update EAPI 7 -> 8 (diff)
downloadgentoo-83b8d8e174d2c106a6a6fb583846acb91c1d88c2.tar.gz
gentoo-83b8d8e174d2c106a6a6fb583846acb91c1d88c2.tar.bz2
gentoo-83b8d8e174d2c106a6a6fb583846acb91c1d88c2.zip
dev-python/pylatex: fix bug 798381
Closes: https://bugs.gentoo.org/798381 Signed-off-by: David Denoncin <ddenoncin@gmail.com> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-python/pylatex')
-rw-r--r--dev-python/pylatex/pylatex-1.4.1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/pylatex/pylatex-1.4.1.ebuild b/dev-python/pylatex/pylatex-1.4.1.ebuild
index b244a3c9b078..a177d4c8eac0 100644
--- a/dev-python/pylatex/pylatex-1.4.1.ebuild
+++ b/dev-python/pylatex/pylatex-1.4.1.ebuild
@@ -36,6 +36,12 @@ BDEPEND+="
dev-texlive/texlive-latexextra
)"
+python_prepare_all() {
+ sed -i -e 's:description-file:description_file:' setup.cfg || die # bug 798381
+
+ distutils-r1_python_prepare_all
+}
+
python_install_all() {
if use examples ; then
dodoc -r examples