summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-16 10:07:10 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-16 10:07:10 +0200
commit027d91aeaf612dfdefa3c7970f937b7a299cf644 (patch)
tree6536033ba1b8bce2b3529f1dc1fe1e5fd92dcc90 /dev-python/pycuda
parentdev-python/pybtex-docutils: Remove old (diff)
downloadgentoo-027d91aeaf612dfdefa3c7970f937b7a299cf644.tar.gz
gentoo-027d91aeaf612dfdefa3c7970f937b7a299cf644.tar.bz2
gentoo-027d91aeaf612dfdefa3c7970f937b7a299cf644.zip
dev-python/pycuda: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycuda')
-rw-r--r--dev-python/pycuda/Manifest1
-rw-r--r--dev-python/pycuda/pycuda-2019.1.2.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/pycuda/Manifest b/dev-python/pycuda/Manifest
index 10348ce0b78a..002986fdfcc4 100644
--- a/dev-python/pycuda/Manifest
+++ b/dev-python/pycuda/Manifest
@@ -1,2 +1 @@
-DIST pycuda-2019.1.2.tar.gz 1584807 BLAKE2B 3250430ad626b28242ff44ab9576cf1f5ecf77530e789470dfebab324de95a735c0f56e67134891bace44b1f9b7a25133ffcb74c652c6568c5afedce26907fdb SHA512 22829daa5923342eec400a24342b1d738226073bb676476e4af97629d9311426b5d2465e60811696e55401568b90e152ac96d877c6262c416099a609862db742
DIST pycuda-2021.1.tar.gz 1682423 BLAKE2B 0ebd7554a5f92cd0d39ce7b5f64218f0b0dcfa1f3e63d3180306a149ad0581150630813eee7fbc17e32bb35ea711a46b84332705d6ffece7b11e7e928ef07aad SHA512 1df09f59e254f7e39b630ff41d22237ab0c81c0e6e7b7611c57eb98ade8531356b9cb3e381e6fa7e8495a46c465458febaf8ad56ceb8d570b5b25defb6dd55a9
diff --git a/dev-python/pycuda/pycuda-2019.1.2.ebuild b/dev-python/pycuda/pycuda-2019.1.2.ebuild
deleted file mode 100644
index a2d14a91432d..000000000000
--- a/dev-python/pycuda/pycuda-2019.1.2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit cuda distutils-r1
-
-DESCRIPTION="Python wrapper for NVIDIA CUDA"
-HOMEPAGE="https://mathema.tician.de/software/pycuda/ https://pypi.org/project/pycuda/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples opengl test"
-
-RDEPEND="
- dev-libs/boost:=[python,${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pytools-2013[${PYTHON_USEDEP}]
- dev-util/nvidia-cuda-toolkit
- x11-drivers/nvidia-drivers
- opengl? ( virtual/opengl )"
-DEPEND="${RDEPEND}"
-
-# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
-# user is (usually) not in the video group
-RESTRICT="userpriv !test? ( test )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- cuda_sanitize
- sed -e "s:'--preprocess':\'--preprocess\', \'--compiler-bindir=$(cuda_gccdir)\':g" \
- -e "s:\"--cubin\":\'--cubin\', \'--compiler-bindir=$(cuda_gccdir)\':g" \
- -e "s:/usr/include/pycuda:${S}/src/cuda:g" \
- -i pycuda/compiler.py || die
-
- touch siteconf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
- cd "${BUILD_DIR}" || die
- "${EPYTHON}" "${S}"/configure.py \
- --boost-inc-dir="${EPREFIX}"/usr/include \
- --boost-lib-dir="${EPREFIX}"/usr/$(get_libdir) \
- --boost-python-libname=boost_${EPYTHON/./}.so \
- --boost-thread-libname=boost_thread \
- --cuda-root="${EPREFIX}"/opt/cuda \
- --cudadrv-lib-dir="${EPREFIX}"/usr/$(get_libdir) \
- --cudart-lib-dir="${EPREFIX}"/opt/cuda/$(get_libdir) \
- --cuda-inc-dir="${EPREFIX}"/opt/cuda/include \
- --no-use-shipped-boost \
- $(usex opengl --cuda-enable-gl "") || die
-}
-
-src_test() {
- # we need write access to this to run the tests
- addwrite /dev/nvidia0
- addwrite /dev/nvidiactl
- addwrite /dev/nvidia-uvm
- addwrite /dev/nvidia-uvm-tools
-
- distutils-r1_src_test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}