summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 22:28:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 23:05:05 +0200
commit5437d9a4ac47ef4822e2caa2aec2aea94e366007 (patch)
tree069ad2e3a22545fc7c97130d2ec416ff82e24655 /dev-python/pyasn1/pyasn1-0.4.8-r2.ebuild
parentdev-python/setuptools-rust: Enable py3.11 (diff)
downloadgentoo-5437d9a4ac47ef4822e2caa2aec2aea94e366007.tar.gz
gentoo-5437d9a4ac47ef4822e2caa2aec2aea94e366007.tar.bz2
gentoo-5437d9a4ac47ef4822e2caa2aec2aea94e366007.zip
dev-python/pyasn1: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyasn1/pyasn1-0.4.8-r2.ebuild')
-rw-r--r--dev-python/pyasn1/pyasn1-0.4.8-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyasn1/pyasn1-0.4.8-r2.ebuild b/dev-python/pyasn1/pyasn1-0.4.8-r2.ebuild
new file mode 100644
index 000000000000..f03009679b3b
--- /dev/null
+++ b/dev-python/pyasn1/pyasn1-0.4.8-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ASN.1 library for Python"
+HOMEPAGE="
+ https://pypi.org/project/pyasn1/
+ https://github.com/etingof/pyasn1/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx "docs/source"