summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-09-25 15:55:23 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-09-25 15:55:44 +0200
commit081b927e8975e0bd5d2dfcb6b82576458ad05b50 (patch)
treec53dbeae6cdce81bb74e1162f4f52219baaf3094 /dev-python/puremagic
parentdev-python/astroid: Keyword 2.8.0 for ~m68k (diff)
downloadgentoo-081b927e8975e0bd5d2dfcb6b82576458ad05b50.tar.gz
gentoo-081b927e8975e0bd5d2dfcb6b82576458ad05b50.tar.bz2
gentoo-081b927e8975e0bd5d2dfcb6b82576458ad05b50.zip
dev-python/puremagic: initial import
Required for net-nntp/sabnzbd. Bug: https://bugs.gentoo.org/814503 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/puremagic')
-rw-r--r--dev-python/puremagic/Manifest1
-rw-r--r--dev-python/puremagic/metadata.xml13
-rw-r--r--dev-python/puremagic/puremagic-1.11.ebuild20
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/puremagic/Manifest b/dev-python/puremagic/Manifest
new file mode 100644
index 000000000000..2e3d2c4c5ae2
--- /dev/null
+++ b/dev-python/puremagic/Manifest
@@ -0,0 +1 @@
+DIST puremagic-1.11.tar.gz 295026 BLAKE2B 4d210807d9f5eb0c2eb88b0c18aa5cdf56170b347de4f95b92c08492d5f038759b39c1aa2d6ed4bc91e96e036e6f4d0891449af8aee3beac65c4d692fa295ec0 SHA512 4d4c9a93cd56a02aefb7090c92b41048f33923bef14022158f39c39ac93326b7180b8cc97495ad5ed3eec7d9f1379a5508829ee779aaba9b8aa8f975e787b1f5
diff --git a/dev-python/puremagic/metadata.xml b/dev-python/puremagic/metadata.xml
new file mode 100644
index 000000000000..9f2ecb2e4c49
--- /dev/null
+++ b/dev-python/puremagic/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/cdgriffith/puremagic/issues</bugs-to>
+ <remote-id type="github">cdgriffith/puremagic</remote-id>
+ <remote-id type="pypi">puremagic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/puremagic/puremagic-1.11.ebuild b/dev-python/puremagic/puremagic-1.11.ebuild
new file mode 100644
index 000000000000..7f02fc5c206e
--- /dev/null
+++ b/dev-python/puremagic/puremagic-1.11.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of magic file detection"
+HOMEPAGE="https://github.com/cdgriffith/puremagic"
+SRC_URI="https://github.com/cdgriffith/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md README.rst )
+
+distutils_enable_tests pytest