summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-06 08:34:54 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-06 08:37:00 +0300
commitc2bb28ab38db7117057851fc202c55ec02b51c42 (patch)
tree56a547c5e93c136554c3e5a3db56ac0ce88177be /dev-python/pip-run
parentdev-ruby/paint: add 2.3.0 (diff)
downloadgentoo-c2bb28ab38db7117057851fc202c55ec02b51c42.tar.gz
gentoo-c2bb28ab38db7117057851fc202c55ec02b51c42.tar.bz2
gentoo-c2bb28ab38db7117057851fc202c55ec02b51c42.zip
dev-python/pip-run: add 8.8.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pip-run')
-rw-r--r--dev-python/pip-run/Manifest1
-rw-r--r--dev-python/pip-run/pip-run-8.8.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index 919e3b249dd7..e5feb840c0e3 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -1 +1,2 @@
DIST pip-run-8.8.0.gh.tar.gz 22145 BLAKE2B 18b915a29a1767022a609e356005e87f035c3d9bab6dd5ab44f9f42668f4d64c4ee5360cb92b217aa2b7b94e0fbfdb5f0e494e668d9bed8badc38ab36cced353 SHA512 301083a34dea08035819024f17d8108f9751a765cdfc8f2e273b948c7746111efedd80765a63c3ac145bdf7d2b41c9a0b2b20286181c4c94cbc5501fb81eb74d
+DIST pip-run-8.8.1.gh.tar.gz 22443 BLAKE2B 4f87e3ec9867971916a0d5c463cdae63c7bb95ba457ff6e04101c1c37ea8728e2db2bad805b10bb6843b5ded1cb095d0f493b02c8a6e73aa4b782b849aa5ffb4 SHA512 ae964ca96f0be33fdb33974061e75486c443fda5edf0cf43247e8bd293d9a6a87d2cd421100578ed5179f13c9f46ff10ec730e0b403982da7e8aac22651268ea
diff --git a/dev-python/pip-run/pip-run-8.8.1.ebuild b/dev-python/pip-run/pip-run-8.8.1.ebuild
new file mode 100644
index 000000000000..4a52697a06ef
--- /dev/null
+++ b/dev-python/pip-run/pip-run-8.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+SRC_URI="
+ https://github.com/jaraco/pip-run/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Needs network access, and another test dep nbformat
+ pip_run/tests/test_scripts.py
+)
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}