summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-26 14:26:39 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-26 15:36:46 +0200
commitd3656dee02415d6fc93faf4c452183cebccd1923 (patch)
treea02b6fc8abd90cce91c8c0ffa444504c6c39d5d5 /dev-python/pdm
parentapp-antivirus/clamav: add 1.1.3, 1.2.1 drop 1.1.2 and 1.2.0 (diff)
downloadgentoo-d3656dee02415d6fc93faf4c452183cebccd1923.tar.gz
gentoo-d3656dee02415d6fc93faf4c452183cebccd1923.tar.bz2
gentoo-d3656dee02415d6fc93faf4c452183cebccd1923.zip
dev-python/pdm: Use pytest-xdist
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pdm')
-rw-r--r--dev-python/pdm/pdm-2.10.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pdm/pdm-2.10.0.ebuild b/dev-python/pdm/pdm-2.10.0.ebuild
index 67faee70f040..829b67f4dbf6 100644
--- a/dev-python/pdm/pdm-2.10.0.ebuild
+++ b/dev-python/pdm/pdm-2.10.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=pdm-backend
PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 pypi
+inherit distutils-r1 multiprocessing pypi
DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
HOMEPAGE="
@@ -45,6 +45,7 @@ BDEPEND="
test? (
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"
@@ -72,5 +73,8 @@ python_test() {
tests/test_project.py::test_project_packages_path
)
- epytest -m "not network and not integration and not path"
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network and not integration and not path" \
+ -p pytest_mock \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
}