summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-13 07:29:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-13 08:04:31 +0200
commit704678ef03dbd007a65296e4e2fa127453bc606f (patch)
tree39255849a833a873b7f3528d77f74d74730fc7bd /dev-python/packaging/packaging-23.1.ebuild
parentdev-python/rich: Bump to 13.3.4 (diff)
downloadgentoo-704678ef03dbd007a65296e4e2fa127453bc606f.tar.gz
gentoo-704678ef03dbd007a65296e4e2fa127453bc606f.tar.bz2
gentoo-704678ef03dbd007a65296e4e2fa127453bc606f.zip
dev-python/packaging: Bump to 23.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/packaging/packaging-23.1.ebuild')
-rw-r--r--dev-python/packaging/packaging-23.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/packaging/packaging-23.1.ebuild b/dev-python/packaging/packaging-23.1.ebuild
new file mode 100644
index 000000000000..670c988ba205
--- /dev/null
+++ b/dev-python/packaging/packaging-23.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="
+ https://github.com/pypa/packaging/
+ https://pypi.org/project/packaging/
+"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/pyparsing-3.0.7-r1[${PYTHON_USEDEP}]
+ !<dev-python/setuptools-67
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --capture=no
+}