summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-28 15:02:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-28 16:50:51 -0500
commit6740aaf406ef733209823dd1beeebbd32a0dafa6 (patch)
treeae0cb16e0ad17f51f6069e21c9ef2d50ae9ea8f8 /dev-python/oslo-reports
parentdev-python/os-brick: 1.15.2 bup (diff)
downloadgentoo-6740aaf406ef733209823dd1beeebbd32a0dafa6.tar.gz
gentoo-6740aaf406ef733209823dd1beeebbd32a0dafa6.tar.bz2
gentoo-6740aaf406ef733209823dd1beeebbd32a0dafa6.zip
dev-python/oslo-reports: 1.22.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/oslo-reports')
-rw-r--r--dev-python/oslo-reports/Manifest1
-rw-r--r--dev-python/oslo-reports/oslo-reports-1.22.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/oslo-reports/Manifest b/dev-python/oslo-reports/Manifest
index 6de242787df9..af4ecb7bae14 100644
--- a/dev-python/oslo-reports/Manifest
+++ b/dev-python/oslo-reports/Manifest
@@ -1,2 +1,3 @@
DIST oslo.reports-1.17.0.tar.gz 47891 SHA256 0f1b825ff32d0b36a1823116a2bddece1bbd17d8f85d8e8e5f8274df80d16852 SHA512 1fded7c8d6149dbbe11fb6fb28f6db656571519fcc093bfa7bf85a8d998c6cf23f28512e0658c9f8f547185f10bfb3b993fdc52942eac5ba884d2ee15556ad20 WHIRLPOOL 61f29933952e474aaac19f77a2165c14db0fc416b2d8e7d38351143dd4ca8af78f9652b099f18fa64ce898bb83a1bb217b97a7985b52dbd451f2cec297e32e77
DIST oslo.reports-1.17.1.tar.gz 47828 SHA256 dbfc364f7d36065cfc369d98c01101f0833ef47f1786e1184296219067044792 SHA512 2ed6d69c8643901a185f38de34cff663160daa246d372503f17e2102634c6634dfafeaa7d6474b7bd702f43aece27a3e4d16c06ccc0a9f6bee1d79a2204ec704 WHIRLPOOL b10c8c8514963df3e87b4993d8419e48f065a1134ea938cf5f3d7e16b9cbea36e97209c1966def6ca79a43f77744a6a3760028a8ea7235531ef8241522f741c8
+DIST oslo.reports-1.22.0.tar.gz 48141 SHA256 2bcfbe73dcd10c04c44aaab2e1579342fdf00652c236c78a0f168069c0cf4cec SHA512 fa4d6f08531c383fbba3fc2785db0c22a21226d477faebe65ae6ede5e2c7db7fbcbb6edd793c38e6f862679e13f2e7e5838ee48784ae554f18ba9363edbbee54 WHIRLPOOL 35a8b605ee86b4d791961f0d02aa8fcd6c87fee97da12384cc41819b41a447909cba122c6e44e71090eb5ed21b12b0b49db9f810c833e2ef3180467a0fe37a36
diff --git a/dev-python/oslo-reports/oslo-reports-1.22.0.ebuild b/dev-python/oslo-reports/oslo-reports-1.22.0.ebuild
new file mode 100644
index 000000000000..ad722b7e1add
--- /dev/null
+++ b/dev-python/oslo-reports/oslo-reports-1.22.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="generified reports for openstack"
+HOMEPAGE="http://docs.openstack.org/developer/oslo.reports"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.reports/oslo.reports-${PV}.tar.gz"
+S="${WORKDIR}/oslo.reports-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
+ !~dev-python/jinja-2.9.0[${PYTHON_USEDEP}]
+ !~dev-python/jinja-2.9.1[${PYTHON_USEDEP}]
+ !~dev-python/jinja-2.9.2[${PYTHON_USEDEP}]
+ !~dev-python/jinja-2.9.3[${PYTHON_USEDEP}]
+ !~dev-python/jinja-2.9.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/psutil-3.2.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}