summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-10-20 18:04:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-10-20 19:18:54 -0500
commit942056047f019a68499f748bd062d4357aca0a4f (patch)
tree1a65a3a99042fe259720f715ac4480329e323637 /dev-python/os-resource-classes/os-resource-classes-0.5.0.ebuild
parentsys-cluster/cinder: 15.0.0 TRAIN bump (diff)
downloadgentoo-942056047f019a68499f748bd062d4357aca0a4f.tar.gz
gentoo-942056047f019a68499f748bd062d4357aca0a4f.tar.bz2
gentoo-942056047f019a68499f748bd062d4357aca0a4f.zip
dev-python/os-resource-classes: 0.5.0 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/os-resource-classes/os-resource-classes-0.5.0.ebuild')
-rw-r--r--dev-python/os-resource-classes/os-resource-classes-0.5.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/os-resource-classes/os-resource-classes-0.5.0.ebuild b/dev-python/os-resource-classes/os-resource-classes-0.5.0.ebuild
new file mode 100644
index 000000000000..ab121613543a
--- /dev/null
+++ b/dev-python/os-resource-classes/os-resource-classes-0.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A list of standardized resource classes for OpenStack."
+HOMEPAGE="https://github.com/openstack/os-resource-classes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}