summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-23 06:29:38 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-23 06:31:09 +0100
commitd2163f6a9bbaad0bde1b344bea4cace8ac0e20c6 (patch)
treebe6060e57b7ae354634d72deda67938a1fc1aa22 /dev-python/mpmath
parentdev-python/mrcfile: Bump to 1.5.4 (diff)
downloadgentoo-d2163f6a9bbaad0bde1b344bea4cace8ac0e20c6.tar.gz
gentoo-d2163f6a9bbaad0bde1b344bea4cace8ac0e20c6.tar.bz2
gentoo-d2163f6a9bbaad0bde1b344bea4cace8ac0e20c6.zip
dev-python/mpmath: Bump to 1.4.0_alpha3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/Manifest1
-rw-r--r--dev-python/mpmath/mpmath-1.4.0_alpha3.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index 43a4ae3426cc..dec165612924 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1 +1,2 @@
DIST mpmath-1.4.0a2.tar.gz 2079112 BLAKE2B 9d2d99dddd4e800b3860f38ef1955b7d803c928d54a7e5d7b07386a127c5a6477818e3ac5c9f679f596c7a2c21bbf430f0bb2348c70ab77d6a888cfb19c6a218 SHA512 523775f3e7d96fd9e0d2c5e4caf855f62d0b683ac00df9dce4fd50d8764bfcf77282fdb34afb51bc53bb303178e7f0e8b6d72700e530d3ca11e3d365b09fc4de
+DIST mpmath-1.4.0a3.tar.gz 2079258 BLAKE2B f57e4603758f8aae879e9e61d42f11303eb3f81c02ee51ea54260ce26fa49013f41c7f6f7d97eea6489c42d490ae4f423c3d7f79052972d6b089fb8a03d47aa0 SHA512 8fd32e98beaf2382a2ec8a92df2a097f2101e746bd3e821b92183b6be560b0fed30daeb0b93d459fad62bea29c425ed142055819a346629d385a1426fb00e611
diff --git a/dev-python/mpmath/mpmath-1.4.0_alpha3.ebuild b/dev-python/mpmath/mpmath-1.4.0_alpha3.ebuild
new file mode 100644
index 000000000000..e1954b4926fc
--- /dev/null
+++ b/dev-python/mpmath/mpmath-1.4.0_alpha3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="
+ https://mpmath.org/
+ https://github.com/mpmath/mpmath/
+ https://pypi.org/project/mpmath/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/gmpy2[${PYTHON_USEDEP}]
+ ' 'python3*')
+ !mips? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ !hppa? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ )
+ )
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # minor whitespace mismatch, apparently fixed in pypy 7.3.18
+ mpmath/tests/test_format.py::test_mpf_floats_bulk
+ mpmath/tests/test_format.py::test_mpc_complexes
+ )
+ ;;
+ esac
+
+ # CLI crashes otherwise, sigh (not a regression)
+ # https://github.com/mpmath/mpmath/issues/907
+ > "${HOME}/.python_history" || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p rerunfailures --reruns=5 -p timeout
+}
+
+pkg_postinst() {
+ optfeature "gmp support" dev-python/gmpy2
+ optfeature "matplotlib support" dev-python/matplotlib
+}