summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-08 07:31:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-08 07:31:48 +0200
commitbed49951dc1a4396c7d7fd1e02120023de96d840 (patch)
tree182f623751448c10789c045e1a3741ee7ea68584 /dev-python/llfuse
parentdev-python/trove-classifiers: Bump to 2023.8.7 (diff)
downloadgentoo-bed49951dc1a4396c7d7fd1e02120023de96d840.tar.gz
gentoo-bed49951dc1a4396c7d7fd1e02120023de96d840.tar.bz2
gentoo-bed49951dc1a4396c7d7fd1e02120023de96d840.zip
dev-python/llfuse: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-1.5.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index e8b852ff2a22..cc8838a972f7 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -1 +1,2 @@
DIST llfuse-1.4.4.tar.gz 293728 BLAKE2B aba684a0b7b06a0cdb97fb8851639ee0c6b5dc100e3d216430e26f122a78ac7933b7d5725f271328804a592b343988d6ceb79bd8c682620464dcef1d26cc20b0 SHA512 3e61f1f82194dc915947e4f0c2edf44ce0e87c4da142e39c2b19bb7db3f387a348f9c1bb02b6d0f2507b57cbfc20ad83c11ce513c685dc276d6a382e4dd449eb
+DIST llfuse-1.5.0.tar.gz 869259 BLAKE2B 2a3eee64718f4a73b8dd51ccaeedd7b1b700f734b10daa864d2ca04da5f38ed6a514c4ae8b541000c4d4a3042dcd95533ff7c1df655d7b57ec89120a97d8a9b6 SHA512 bb84c697658e7cd39eb6af3a4a6085c3bc3295e5f0b4f35adf6565ecff5077acb27ecd92f7c6420aa06dab36d9b54915bce65e4ec3d011047a0a15cdccbbb284
diff --git a/dev-python/llfuse/llfuse-1.5.0.ebuild b/dev-python/llfuse/llfuse-1.5.0.ebuild
new file mode 100644
index 000000000000..20eec20ecf4b
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.5.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="
+ https://github.com/python-llfuse/python-llfuse/
+ https://pypi.org/project/llfuse/
+"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=sys-fs/fuse-2.8.0:0
+"
+DEPEND="
+ ${RDEPEND}
+ sys-apps/attr
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/llfuse-1.3.5-cflags.patch
+)
+
+distutils_enable_sphinx rst
+distutils_enable_tests pytest
+
+src_prepare() {
+ # force regen
+ rm src/llfuse.c || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ if [[ ! -f src/llfuse.c ]]; then
+ esetup.py build_cython
+ fi
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}