summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2024-01-17 10:25:44 +0100
committerSam James <sam@gentoo.org>2024-01-18 19:46:24 +0000
commite7ed93a0ff72c171532a90b85b9025bf9cc145c4 (patch)
tree8e88b99cc3bd9c8c79b7baec9d09133381ad26b2 /dev-python/libvirt-python
parentapp-emacs/nxml-libvirt-schemas: Add 10.0.0 (diff)
downloadgentoo-e7ed93a0ff72c171532a90b85b9025bf9cc145c4.tar.gz
gentoo-e7ed93a0ff72c171532a90b85b9025bf9cc145c4.tar.bz2
gentoo-e7ed93a0ff72c171532a90b85b9025bf9cc145c4.zip
dev-python/libvirt-python: Add 10.0.0
Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest2
-rw-r--r--dev-python/libvirt-python/libvirt-python-10.0.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 8eff26eb4185..f597672f511e 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,3 +1,5 @@
+DIST libvirt-python-10.0.0.tar.gz 246385 BLAKE2B 0d3411d5d138fe57c6a5b73423479939182a4b9fde29c74ea832db3664db7da392bb15f0381c3ead949c36554cfdbf322441380293ffb016377dc9d4a6b57756 SHA512 4c3f51b2669ad7dc571f05ddeb75bb375640d27f77c1511e6682d8c7a77074210c48ea6c2e125ce8b04a1512df8a6a41e6a2d291e853dcaff84da213c89a6097
+DIST libvirt-python-10.0.0.tar.gz.asc 833 BLAKE2B f90f76364c84dff7f7346ea06a630b7085f9c6c7c9bf671cc152287f2123a4f8d1fd8734c3a2771468a8e4748fb7e8628738403b45e688dc36d3972999ff24bf SHA512 fd6048d6a8f73145e7e0512e55a86740a923c671b75aa505cb58291e9809d9927400eabf636db94d9e7093b3eb2c11df0e36d8de24ba9944ae05a8885201ebab
DIST libvirt-python-9.3.0.tar.gz 244181 BLAKE2B 1f472233ea336bf7196f83c41606817c6422b08ba76bb07a39510018498cc378a3e31626155e9953881ac4718ca642df6878e9a2b6bfe74116052819fabf63c6 SHA512 5fe04eb6fbccb20f90637d5bb74887b0676743761838c91f6c7f08f8aff39ea8e1d8cdc50c4c244918c2100efb00c6bb380ac44b4d403a08863c8c99ecdbe937
DIST libvirt-python-9.3.0.tar.gz.asc 833 BLAKE2B bb3f47ce3dea2fca251a956c170f98406485f3b738e068d6b3dab59c5f440aba7127683f484278866d5b39f53cd18a5dbb9697e701515c6d93141b3e7ecae18b SHA512 0123bc657ec2680ea998e70c62f2dba0f5960239faa43158e4897e4e3e287a0fdb29daa409bf98514b271477410308c959a0ab1e4e90fa82f409cd4f858201fe
DIST libvirt-python-9.4.0.tar.gz 244574 BLAKE2B cdba846dc9e1c5023a0d8fe22da9f539f8b2946512eed6f74ff9c3516335c580d72d50609bab100a0f50289295cf8402e0d7c695a5afbe1ed989f89f758ee2ee SHA512 899d88009b54b1c6e225f609bf121d7b7ea7558fc8562a01b6b46d828c4882c01b3b129263f68354b5576727e2626d63ba12e6ff33bca2bad14ace75942d6069
diff --git a/dev-python/libvirt-python/libvirt-python-10.0.0.ebuild b/dev-python/libvirt-python/libvirt-python-10.0.0.ebuild
new file mode 100644
index 000000000000..83f8a3a26364
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-10.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Packages which get releases together:
+# app-emacs/nxml-libvirt-schemas
+# dev-python/libvirt-python
+# dev-perl/Sys-Virt
+# app-emulation/libvirt
+# Please bump them together!
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 verify-sig
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/libvirt/libvirt-python.git"
+ RDEPEND="app-emulation/libvirt:="
+else
+ MY_P="${P/_rc/-rc}"
+ SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz
+ verify-sig? ( https://libvirt.org/sources/python/${MY_P}.tar.gz.asc )"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+ verify-sig? ( sec-keys/openpgp-keys-libvirt )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/libvirt.org.asc
+
+distutils_enable_tests pytest
+
+python_compile() {
+ # setuptools is broken for C extensions, bug #907718
+ distutils-r1_python_compile -j1
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}