summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-14 08:48:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-14 08:48:16 +0100
commit97268176352f52f2ed50a716cdb1b032180a2686 (patch)
tree682532237c64b848187695be13ca93e06c633d2b /dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
parentdev-python/hypothesis: Bump to 6.8.1 (diff)
downloadgentoo-97268176352f52f2ed50a716cdb1b032180a2686.tar.gz
gentoo-97268176352f52f2ed50a716cdb1b032180a2686.tar.bz2
gentoo-97268176352f52f2ed50a716cdb1b032180a2686.zip
dev-python/jupyter_client: Bump to 6.1.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client/jupyter_client-6.1.12.ebuild')
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.12.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
new file mode 100644
index 000000000000..8f92382aed2c
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ <dev-python/jedi-0.17.3[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest