summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-08-07 19:25:19 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-08-07 19:25:26 -0700
commite1968c1960f2e990be87840b3b53cbd52c18ee82 (patch)
treed4780672e150edd40457e82f5829127ee7f973d5 /dev-python/jsonschema
parentsys-libs/binutils-libs: Stabilize 2.40-r5 hppa, #909412 (diff)
downloadgentoo-e1968c1960f2e990be87840b3b53cbd52c18ee82.tar.gz
gentoo-e1968c1960f2e990be87840b3b53cbd52c18ee82.tar.bz2
gentoo-e1968c1960f2e990be87840b3b53cbd52c18ee82.zip
dev-python/jsonschema: add 4.19.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.19.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 0bd51a9f4994..7ff5a3e01a0e 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -4,3 +4,4 @@ DIST jsonschema-4.18.2.tar.gz 314916 BLAKE2B 4e63e56ea34b0f315e0ee6e506157c29403
DIST jsonschema-4.18.3.tar.gz 315165 BLAKE2B 486e36cab882628a9f720c098f91f1bafbc34f6e91391f3b4d2c1895e38c6dc8b4c554e37acab23da743c29fe6fefe28243aa6e32da7322a4e2ed1b1f490fad6 SHA512 ae8c18a102b778fe99030082ec0343af0d1c5bead923c431d3242687bf8406bff0d1c7ee6c8dfce56b41bddbfdd47af67129d229903bde051920c900229a4c58
DIST jsonschema-4.18.4.tar.gz 315212 BLAKE2B f931a5469653cb9ecba50b8e79ddf70b1f2b730db6bce3a91a374ae177dfb812f4492fd53a16f2a563787682c2c34618cac16adbc891d59089eb03fcdb8a46a4 SHA512 b7c3805460d5d49c48039f50e616ee35204cb3222384cd1f57029a04fd19c4dcab5a700770ad36c3616cce85cce902abddf4361f7a7fa044318255967ecbfcf5
DIST jsonschema-4.18.6.tar.gz 316619 BLAKE2B 1036a340b5605107855565ce68403acbfee85f736c8ded4debfa3bd680014f69308f86ee1514907dc67683658cf23d298cf506cf23ec19d5a4eb2816c034a050 SHA512 92a3b6b06c94426d7851547c4ea6d3c6e4eb12fb45b58030f10cc5772d1ec2ca332d443e82bd7f448e83fabaebbe0be7e3c0266569bcd815d1e36970f6966fe9
+DIST jsonschema-4.19.0.tar.gz 317546 BLAKE2B a554e5c26fe13c09f6e050c193c6608e9286660e75d555dad574b16b32a24667b5450d452079b714dace657f2aade7621c0c79b4585c4a8ac659f9242ed528f0 SHA512 95cc156fe0505da469600cdbaaf921853a983d45f6b8570e5bbffe9ee41abbf5757b2ccddde443b0d833a3ebdcbff321bda54b136b47d7650d3a40f6402338fb
diff --git a/dev-python/jsonschema/jsonschema-4.19.0.ebuild b/dev-python/jsonschema/jsonschema-4.19.0.ebuild
new file mode 100644
index 000000000000..7902dd518a93
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.19.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-specifications-2023.03.6[${PYTHON_USEDEP}]
+ >=dev-python/referencing-0.28.4[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri_template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # fragile warning tests
+ jsonschema/tests/test_deprecations.py
+ # wtf?
+ jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
+)