summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-08 08:42:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-08 10:51:57 +0200
commit15279183c5e88e7a433fe667b10280f79a25f372 (patch)
treed591bf79ee5970b1e5163729a1c5ee593256fa9b /dev-python/jaraco-logging
parentdev-python/tempora: Enable python3.10 (diff)
downloadgentoo-15279183c5e88e7a433fe667b10280f79a25f372.tar.gz
gentoo-15279183c5e88e7a433fe667b10280f79a25f372.tar.bz2
gentoo-15279183c5e88e7a433fe667b10280f79a25f372.zip
dev-python/jaraco-logging: Enable python3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-logging')
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild
index 2e8b75674ba0..9a25e08b7941 100644
--- a/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild
+++ b/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
@@ -30,8 +30,8 @@ distutils_enable_tests pytest
python_test() {
# Override pytest options to skip flake8
- PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
+ local -x PYTHONPATH=.
+ epytest --override-ini="addopts=--doctest-modules"
}
# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages