summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-05 06:25:20 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-05 06:25:20 +0100
commitb24e9b8207c8436f446dd5b320cc41fb75af614a (patch)
tree36ab040cf7a31d4d83289671f0a12f9cc1c0c5f5 /dev-python/jaraco-functools
parentdev-python/starlette: Bump to 0.32.0 (diff)
downloadgentoo-b24e9b8207c8436f446dd5b320cc41fb75af614a.tar.gz
gentoo-b24e9b8207c8436f446dd5b320cc41fb75af614a.tar.bz2
gentoo-b24e9b8207c8436f446dd5b320cc41fb75af614a.zip
dev-python/jaraco-functools: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-functools')
-rw-r--r--dev-python/jaraco-functools/Manifest1
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-4.0.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/jaraco-functools/Manifest b/dev-python/jaraco-functools/Manifest
index 776acc3b7c86..84fbd9fb1e9f 100644
--- a/dev-python/jaraco-functools/Manifest
+++ b/dev-python/jaraco-functools/Manifest
@@ -1 +1,2 @@
DIST jaraco.functools-3.9.0.tar.gz 17221 BLAKE2B 2476e7cc9440ac21abf4c7d4d5af5d98f7a48c6fb55ef93428936265843a0e9bd02b22e8a2a748e7844015c530bc46ad67be8447b0eddb9b7ddcc1522b53c42b SHA512 5ec081aa07e736b6cacc1f6213e3212b4828824e86033b440d4fc630b0a9cf8e67497b37a239e167e421c41852ea6c0c65a4ccd39d73cc7f1cb831f605b86f00
+DIST jaraco.functools-4.0.0.tar.gz 17779 BLAKE2B ef403411f60e956a723350c949cdbd13fa36473ce77f6b1cea4eb5eaedbd2edd4ea902b8c062d53411c7bc12dcfd3879b0f1c82a1d21c28575f0298eb03f868d SHA512 2545bf3b9c9357ae867e7a5627582e14d0bdf25bac6acc5fbbb7e86f7aa24bc33b5bca584543b4180abdde203610b9716950110253045c1fe11f8bd045283c78
diff --git a/dev-python/jaraco-functools/jaraco-functools-4.0.0.ebuild b/dev-python/jaraco-functools/jaraco-functools-4.0.0.ebuild
new file mode 100644
index 000000000000..598e289a4315
--- /dev/null
+++ b/dev-python/jaraco-functools/jaraco-functools-4.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.functools/
+ https://pypi.org/project/jaraco.functools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/more-itertools-0.12.0-r1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.functools"
+ version = "${PV}"
+ description = "Functools like those found in stdlib"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}functools-${PV}.dist-info || die
+}