summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ipdb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ipdb')
-rw-r--r--dev-python/ipdb/Manifest2
-rw-r--r--dev-python/ipdb/ipdb-0.8.1.ebuild28
-rw-r--r--dev-python/ipdb/ipdb-0.8.ebuild27
-rw-r--r--dev-python/ipdb/metadata.xml8
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/ipdb/Manifest b/dev-python/ipdb/Manifest
new file mode 100644
index 000000000000..df75a4d35c2b
--- /dev/null
+++ b/dev-python/ipdb/Manifest
@@ -0,0 +1,2 @@
+DIST ipdb-0.8.1.zip 20522 SHA256 1763d1564113f5eb89df77879a8d3213273c4d7ff93dcb37a3070cdf0c34fd7c SHA512 515f282cb82ea989670a77956c02ac6433c125beba94c67b1eb90058c2427aac2345d02bb64b71a9593abbf7539d5ab0c20675bd24dde294b1e00544748da65c WHIRLPOOL 3e91eced09d5da6a0fc5442a6df97947fdd018bf73cd52ce0f4800e12f0a1c92f3168c3a171395e601669238b9cbebae0507cce60ca2db02a7f2610ffd73afc2
+DIST ipdb-0.8.zip 20204 SHA256 0d4a33f38e667a0c80ec1a5a0e468fe58e5cdc61cb8f4077b1024b85fe7b7117 SHA512 8d0c510a80efeb3ca9a87e4a573bbd0d75629789dec33ebd135f8c9285a276af2cfe5b6628d0bb121a3dbf9e6f248a19a341d9b475b7bfaa15bb9bdca0584dde WHIRLPOOL 376a2c872ae45e943fb99e8cc201f8d8e2a3ebcdc84dde5d1857269170ab6379d8eb2106567484d4eb2454a5c38e6c355d7a136cf74fab40b907fcabef2d6b8f
diff --git a/dev-python/ipdb/ipdb-0.8.1.ebuild b/dev-python/ipdb/ipdb-0.8.1.ebuild
new file mode 100644
index 000000000000..ff00441040c6
--- /dev/null
+++ b/dev-python/ipdb/ipdb-0.8.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="IPython-enabled pdb"
+HOMEPAGE="http://pypi.python.org/pypi/ipdb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( HISTORY.txt )
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/ipdb/ipdb-0.8.ebuild b/dev-python/ipdb/ipdb-0.8.ebuild
new file mode 100644
index 000000000000..49c5033317ea
--- /dev/null
+++ b/dev-python/ipdb/ipdb-0.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="IPython-enabled pdb"
+HOMEPAGE="http://pypi.python.org/pypi/ipdb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( HISTORY.txt )
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/ipdb/metadata.xml b/dev-python/ipdb/metadata.xml
new file mode 100644
index 000000000000..8cf02f9346c7
--- /dev/null
+++ b/dev-python/ipdb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">ipdb</remote-id>
+ </upstream>
+</pkgmetadata>