summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-24 07:32:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-24 07:52:07 +0200
commitc89ffd6ebfde43673f1a247067ec5d5c76ea2090 (patch)
tree2f9622bb4df7c1cd442c06eedf8ac9dbdf9575ef /dev-python/idna
parentdev-python/Faker: Bump to 28.0.0 (diff)
downloadgentoo-c89ffd6ebfde43673f1a247067ec5d5c76ea2090.tar.gz
gentoo-c89ffd6ebfde43673f1a247067ec5d5c76ea2090.tar.bz2
gentoo-c89ffd6ebfde43673f1a247067ec5d5c76ea2090.zip
dev-python/idna: Bump to 3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/idna')
-rw-r--r--dev-python/idna/Manifest1
-rw-r--r--dev-python/idna/idna-3.8.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/idna/Manifest b/dev-python/idna/Manifest
index ca35c4d0d260..f43706396df4 100644
--- a/dev-python/idna/Manifest
+++ b/dev-python/idna/Manifest
@@ -1 +1,2 @@
DIST idna-3.7.tar.gz 189575 BLAKE2B b604f5e69775b6052e3358a31ea0154832264979a992db51130a0f0e7c5ef9163e97e15956cfd599212ba233c789706a4a2ea8051c3baeda5abc3657bdf40902 SHA512 b50e5ae117b67c7076125d6943e3436200676f85d7dd1b5a5414e217e73904ef077f0b1108d9781ab4afe2a66f7c9e1ce8262ce51edeb2d29e4c504147b6c4cc
+DIST idna-3.8.tar.gz 189467 BLAKE2B e70c754f3a76807d2df9df09b19ec9ea8e98de19f81741dfbb2f828ebd0ac6385e2c0d2fab83206b4c592b40f0b785ed0078eafc0d0339cd9ff53440051c511d SHA512 5ea57a0e21621722375b8b3b90831c1e367f738d7d96d27143990d25ef26d374bcd306956a785ebe6283445642c39b8f655ab4de4b407055e350d11012acdb62
diff --git a/dev-python/idna/idna-3.8.ebuild b/dev-python/idna/idna-3.8.ebuild
new file mode 100644
index 000000000000..c34116d7be8a
--- /dev/null
+++ b/dev-python/idna/idna-3.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="
+ https://github.com/kjd/idna/
+ https://pypi.org/project/idna/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests unittest