summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-29 06:01:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-29 06:01:22 +0200
commit80341ec734f64510a56c79d41423baba83e15da5 (patch)
tree99d17982ac75c86b3fc994457dc3a46d84a143ca /dev-python/hypercorn
parentdev-python/netaddr: Bump to 1.3.0 (diff)
downloadgentoo-80341ec734f64510a56c79d41423baba83e15da5.tar.gz
gentoo-80341ec734f64510a56c79d41423baba83e15da5.tar.bz2
gentoo-80341ec734f64510a56c79d41423baba83e15da5.zip
dev-python/hypercorn: Bump to 0.17.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypercorn')
-rw-r--r--dev-python/hypercorn/Manifest1
-rw-r--r--dev-python/hypercorn/hypercorn-0.17.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/hypercorn/Manifest b/dev-python/hypercorn/Manifest
index 344c972003c9..79bf6c04689f 100644
--- a/dev-python/hypercorn/Manifest
+++ b/dev-python/hypercorn/Manifest
@@ -1,2 +1,3 @@
DIST hypercorn-0.16.0.gh.tar.gz 159038 BLAKE2B d17fde74af7f3a0157af22465f52a46967b8c4297eb5f602614d5337ca511d365e391630495535b56650fc4bfac864d30c5b281c04beddb0fec9bfcecd0f0c00 SHA512 75d75f0a0c1726b83d8ee38d5a15f4241130369904c9925cc3b87d1bf92f0d6a59ae7e7c83434c60ceae4bb628f6a51a42eda00c68a226c0bea6ef1c6fb8cb2c
DIST hypercorn-0.17.2.gh.tar.gz 162107 BLAKE2B f5db0c323c6bbf4dbb7d28617adf1a55fa810e165129d945b410e6810c8f0cc41c6dd8043f846f00405d56760ad94b807b53b104a97396277d98c33d6598b7d6 SHA512 c840eb34fb6e12c236c1d279ba94752a3a1d9ba3f73e519ff71628a648580e7ef6196f5f806053c601531b12af11aa455801a6c2c13cabf3729e55581ffbb881
+DIST hypercorn-0.17.3.gh.tar.gz 162354 BLAKE2B 60e5e0edbf60330e1a172d8b86ed1e0b2bfbb047dca22bf9eecfd672d8bdcf7a224658d0b5b123fb5f63fcff74ad2928760df58c1be065e4849c5bd36cc5f90f SHA512 d1dd42445af580d4083cfae906cbed7d74b9378be93b476ef2188744f9f17a041b496b270847a8a47ffd99198513f6133942367fc7a11d4d502353c1204a1abb
diff --git a/dev-python/hypercorn/hypercorn-0.17.3.ebuild b/dev-python/hypercorn/hypercorn-0.17.3.ebuild
new file mode 100644
index 000000000000..9a7296e4811f
--- /dev/null
+++ b/dev-python/hypercorn/hypercorn-0.17.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A ASGI Server based on Hyper libraries and inspired by Gunicorn"
+HOMEPAGE="
+ https://github.com/pgjones/hypercorn/
+ https://pypi.org/project/Hypercorn/
+"
+SRC_URI="
+ https://github.com/pgjones/hypercorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/h11[${PYTHON_USEDEP}]
+ >=dev-python/h2-3.1.0[${PYTHON_USEDEP}]
+ dev-python/priority[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.1.0[${PYTHON_USEDEP}]
+ dev-python/taskgroup[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/wsproto-0.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--no-cov-on-fail::' pyproject.toml || die
+ distutils-r1_src_prepare
+}