summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-07-22 15:14:03 +0200
committerAgostino Sarubbo <ago@gentoo.org>2020-07-22 15:14:03 +0200
commitfd402ec588ffcce9db9d9b0f99e1ac37ecc179b7 (patch)
treed70ec2fb22ac275ad87bf32ada3600eff6c50251 /dev-python/hcloud-python
parentx11-misc/birdtray: remove old (diff)
downloadgentoo-fd402ec588ffcce9db9d9b0f99e1ac37ecc179b7.tar.gz
gentoo-fd402ec588ffcce9db9d9b0f99e1ac37ecc179b7.tar.bz2
gentoo-fd402ec588ffcce9db9d9b0f99e1ac37ecc179b7.zip
dev-python/hcloud-python: version bump to 1.8.2
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest1
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.8.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index 2fef7adc80be..a93b770401f0 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1 +1,2 @@
DIST hcloud-python-1.8.1.tar.gz 87532 BLAKE2B d5e2b5d2aef96508042189d650ef0c6793ca8747a99f20c591c63dbeed497576ef6cf268f75cdc5551b9b3469f1087d5d2ad167af77a93ab321cc9c70d1bb65b SHA512 e26976abe77149db53ea8a35e53de85e0acc3b2021ecbfb1a3a634230d2324e2fb212f54cfcb7a96993b4776d305a247b29aa883053958db881a794f431858bd
+DIST hcloud-python-1.8.2.tar.gz 87560 BLAKE2B 836b0422364e50567cfa31e1a77e0b4a28da4419a0991f1635d6d0366368315ae914d238fab974fb1ba2c5e09172e3edfc625d40c6c099d757fa1c7913dba68b SHA512 8436b57e9a0e5b8fb44f9242c9862835a5e027ee2d774e3dd1b55834f5a574c4f21a543ac9c7d0a105048bd184e7278a3bb4f94a7ee5e18bfb419f0ca59183eb
diff --git a/dev-python/hcloud-python/hcloud-python-1.8.2.ebuild b/dev-python/hcloud-python/hcloud-python-1.8.2.ebuild
new file mode 100644
index 000000000000..38732655eab6
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.8.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
+SRC_URI="https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+COMMON_DEPEND=">=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]"
+
+BDEPEND="${COMMON_DEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme
+ )
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/future-0.17.1[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
+
+distutils_enable_tests pytest
+
+src_test() {
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ rm -fr tests/integration
+ default
+}