summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-06-09 15:39:36 +0200
committerAgostino Sarubbo <ago@gentoo.org>2020-06-09 15:39:36 +0200
commit9a5340b2b9f6cd016af62d25e30edd3f888f4c10 (patch)
tree9130ceb83e86f21df4f23d54e6a8f8b38d220cc1 /dev-python/hcloud-python
parentsys-auth/pam_passwdqc: make ci hapy (diff)
downloadgentoo-9a5340b2b9f6cd016af62d25e30edd3f888f4c10.tar.gz
gentoo-9a5340b2b9f6cd016af62d25e30edd3f888f4c10.tar.bz2
gentoo-9a5340b2b9f6cd016af62d25e30edd3f888f4c10.zip
dev-python/hcloud-python: version bump to 1.7.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest1
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.7.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index 98d9fc275ea4..a17c82a0a4f4 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1 +1,2 @@
DIST hcloud-python-1.6.3.tar.gz 71575 BLAKE2B a6c969d713d1351bba0cebef8752abbbf0805b4a39eedc918767ccf60d590ac8259e1405a25c2c563923146d52ae1318d6362cbaee311bfe04bea5afcc18951b SHA512 dec3f16197de9f02c2707601e1cad40289d3ccbd6256887da50b84fb8fe6b0fb98f708c9ba0cfc2ff1308a53b9997cfda579df3ec79a1d28686a3c43f4124e74
+DIST hcloud-python-1.7.0.tar.gz 71683 BLAKE2B 43dfda161505d9aa486487a028dff9406e77f3c33efe935c13faf19503d1cd98a136703939408b0faf50633c1a40bbd5c43d90a6373acb38e8a0d61bf715a02a SHA512 d8fac8b74862d5f59f50ddac4f675c409f0bb5b51b16c6db094acae2323214c623bdb459c7fe0e74bb21fc88aa61e551b951cfa6c7de4504a4bf31c7f9481f2e
diff --git a/dev-python/hcloud-python/hcloud-python-1.7.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.7.0.ebuild
new file mode 100644
index 000000000000..2f3b9f4100c1
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
+SRC_URI="https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+COMMON_DEPEND=">=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-2.9[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+ <dev-python/requests-2.23[${PYTHON_USEDEP}]"
+
+BDEPEND="${COMMON_DEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme
+ )
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/future-0.17.1[${PYTHON_USEDEP}]
+ <dev-python/future-0.19[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
+
+distutils_enable_tests pytest
+
+src_test() {
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ rm -fr tests/integration
+ default
+}