summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-16 19:09:47 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-16 19:11:16 +0100
commit67b48238f67f37ae1e2ad6430cfedbd29669fc07 (patch)
treef769d5b26b439cd05ee96b2118bdf3008537d664 /dev-python/h2
parentdev-python/h11: Remove old (diff)
downloadgentoo-67b48238f67f37ae1e2ad6430cfedbd29669fc07.tar.gz
gentoo-67b48238f67f37ae1e2ad6430cfedbd29669fc07.tar.bz2
gentoo-67b48238f67f37ae1e2ad6430cfedbd29669fc07.zip
dev-python/h2: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/h2')
-rw-r--r--dev-python/h2/Manifest1
-rw-r--r--dev-python/h2/h2-3.2.0-r1.ebuild58
-rw-r--r--dev-python/h2/h2-3.2.0.ebuild52
3 files changed, 0 insertions, 111 deletions
diff --git a/dev-python/h2/Manifest b/dev-python/h2/Manifest
index d54c669d7be3..59642403e537 100644
--- a/dev-python/h2/Manifest
+++ b/dev-python/h2/Manifest
@@ -1,2 +1 @@
DIST h2-4.1.0.tar.gz 2143812 BLAKE2B b9d9a771340b4bde1675b9fd65c242732a1a262456f84a409662cf2b57326e24e0583160ba0531c0b105b79342578714127dddb560d2a27de58af34d1052c698 SHA512 4e9cf88b3ae702a8a42bded775ad337809787fe8172d501c230d55abbf1edd764acf3b227f2e58756d882499661ffcf6bbdd4812a4d938c04fac3f1aa2390b28
-DIST hyper-h2-3.2.0.tar.gz 2203333 BLAKE2B 245bab162852070e850613c41162c75efe5e43535945dacf448afdc948cade83402f77259aa46f375d0772a5287e42d8842b1259cb36392cc8fc222dec7cef75 SHA512 103a4ea2cd29037ce03ae676864125b4111c7d31a82bbbe7028557da886d88fb5363d885f08d5d3f68dfa29013b7b03350cc0cb4d9dddf32735e98dae5d7fc7c
diff --git a/dev-python/h2/h2-3.2.0-r1.ebuild b/dev-python/h2/h2-3.2.0-r1.ebuild
deleted file mode 100644
index 635a9a4ab055..000000000000
--- a/dev-python/h2/h2-3.2.0-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-MY_P=hyper-h2-${PV}
-DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
-HOMEPAGE="
- https://python-hyper.org/projects/h2/en/stable/
- https://github.com/python-hyper/h2/
- https://pypi.org/project/h2/
-"
-SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/hyperframe-5.2.0[${PYTHON_USEDEP}]
- <dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/hpack-3.0.0[${PYTHON_USEDEP}]
- <dev-python/hpack-4.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # From https://github.com/python-hyper/h2/pull/1248
- # Disables some failing healthchecks
- "${FILESDIR}/hyper-h2-3.2.0-failed-healthcheck.patch"
-)
-
-python_test() {
- local EPYTEST_DESELECT=()
- [[ ${EPYTHON} == python3.1[01] ]] && EPYTEST_DESELECT+=(
- # these rely on fixed string repr() and fail because enum repr
- # changed in py3.10
- test/test_basic_logic.py::TestBasicServer::test_stream_repr
- test/test_events.py::TestEventReprs::test_remotesettingschanged_repr
- test/test_events.py::TestEventReprs::test_streamreset_repr
- test/test_events.py::TestEventReprs::test_settingsacknowledged_repr
- test/test_events.py::TestEventReprs::test_connectionterminated_repr
- )
-
- epytest --hypothesis-profile=travis
-}
diff --git a/dev-python/h2/h2-3.2.0.ebuild b/dev-python/h2/h2-3.2.0.ebuild
deleted file mode 100644
index 9906283c1f83..000000000000
--- a/dev-python/h2/h2-3.2.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
-inherit distutils-r1
-
-MY_P=hyper-h2-${PV}
-DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
-HOMEPAGE="https://python-hyper.org/h2/en/stable/ https://pypi.org/project/h2/"
-SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/hyperframe-5.2.0[${PYTHON_USEDEP}]
- <dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/hpack-3.0.0[${PYTHON_USEDEP}]
- <dev-python/hpack-4.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # From https://github.com/python-hyper/h2/pull/1248
- # Disables some failing healthchecks
- "${FILESDIR}/hyper-h2-3.2.0-failed-healthcheck.patch"
-)
-
-python_test() {
- local deselect=()
- [[ ${EPYTHON} == python3.10 ]] && deselect+=(
- # these rely on fixed string repr() and fail because enum repr
- # changed in py3.10
- test/test_basic_logic.py::TestBasicServer::test_stream_repr
- test/test_events.py::TestEventReprs::test_remotesettingschanged_repr
- test/test_events.py::TestEventReprs::test_streamreset_repr
- test/test_events.py::TestEventReprs::test_settingsacknowledged_repr
- test/test_events.py::TestEventReprs::test_connectionterminated_repr
- )
-
- epytest --hypothesis-profile=travis ${deselect[@]/#/--deselect }
-}