summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/fusil
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/fusil')
-rw-r--r--dev-python/fusil/Manifest1
-rw-r--r--dev-python/fusil/files/1.4-python25.patch12
-rw-r--r--dev-python/fusil/fusil-1.5.ebuild37
-rw-r--r--dev-python/fusil/metadata.xml9
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/fusil/Manifest b/dev-python/fusil/Manifest
new file mode 100644
index 000000000000..69efd20565a5
--- /dev/null
+++ b/dev-python/fusil/Manifest
@@ -0,0 +1 @@
+DIST fusil-1.5.tar.gz 138910 SHA256 1b6e269f47636b5fd1ddd25940aa1beaae68c05c076b3ad6bcef72db5865729b SHA512 0d84bfd2d9b8e509989723de26b30c3ec2824612dbdcc097ff3e998fd4efa6b1293cb78743e098ad5012d4981b8e8036f3ad3f9c6acf2dc30e3ff1f707c7d1c0 WHIRLPOOL d0747c9f53af8ccaa9155fa05726928b0a52b5cef6fc76f7ab38b3219ca3d1c82c396737de3427fe3129d257f91853659ea7f2ab158c31a4349b53d906c5121d
diff --git a/dev-python/fusil/files/1.4-python25.patch b/dev-python/fusil/files/1.4-python25.patch
new file mode 100644
index 000000000000..b36643b5c4a7
--- /dev/null
+++ b/dev-python/fusil/files/1.4-python25.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 712796e..40ea469 100755
+--- a/setup.py
++++ b/setup.py
+@@ -17,6 +17,7 @@
+ # - set version to n+1
+ # - add a new empty section in the changelog for version n+1
+
++from __future__ import with_statement
+ from imp import load_source
+ from os import path
+ from sys import argv
diff --git a/dev-python/fusil/fusil-1.5.ebuild b/dev-python/fusil/fusil-1.5.ebuild
new file mode 100644
index 000000000000..befb160edbdf
--- /dev/null
+++ b/dev-python/fusil/fusil-1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 user
+
+DESCRIPTION="Fusil the fuzzer is a Python library used to write fuzzing programs"
+HOMEPAGE="http://bitbucket.org/haypo/fusil/wiki/Home http://pypi.python.org/pypi/fusil"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+
+DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/python-ptrace-0.7[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ if use doc; then
+ emake -C doc RST2HTML="rst2html.py" || die "Generation of documentation failed"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ enewgroup fusil
+ enewuser fusil -1 -1 -1 "fusil"
+}
diff --git a/dev-python/fusil/metadata.xml b/dev-python/fusil/metadata.xml
new file mode 100644
index 000000000000..c9788744da70
--- /dev/null
+++ b/dev-python/fusil/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">fusil</remote-id>
+ <remote-id type="bitbucket">haypo/fusil</remote-id>
+ </upstream>
+</pkgmetadata>