summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-27 11:17:00 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-27 12:29:05 +0300
commita29c3a7e0e76015c5749d048d4f8ddf895884157 (patch)
tree5b8809e21bdfcb0208bb5062a04b63aa531eda1a /dev-python/flufl-testing/flufl-testing-0.8.ebuild
parentdev-python/nose2: enable py3.10 (diff)
downloadgentoo-a29c3a7e0e76015c5749d048d4f8ddf895884157.tar.gz
gentoo-a29c3a7e0e76015c5749d048d4f8ddf895884157.tar.bz2
gentoo-a29c3a7e0e76015c5749d048d4f8ddf895884157.zip
dev-python/flufl-testing: new NIH test dep of net-mail/mailman
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flufl-testing/flufl-testing-0.8.ebuild')
-rw-r--r--dev-python/flufl-testing/flufl-testing-0.8.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/flufl-testing/flufl-testing-0.8.ebuild b/dev-python/flufl-testing/flufl-testing-0.8.ebuild
new file mode 100644
index 000000000000..b2212bd8e62e
--- /dev/null
+++ b/dev-python/flufl-testing/flufl-testing-0.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/-/.}
+
+DESCRIPTION="Small collection of test tool plugins"
+HOMEPAGE="https://gitlab.com/warsaw/flufl.testing https://pypi.org/project/flufl.testing/"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/nose2[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}