summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/flask-xml-rpc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/flask-xml-rpc')
-rw-r--r--dev-python/flask-xml-rpc/Manifest1
-rw-r--r--dev-python/flask-xml-rpc/flask-xml-rpc-0.1.2-r1.ebuild30
-rw-r--r--dev-python/flask-xml-rpc/metadata.xml8
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/flask-xml-rpc/Manifest b/dev-python/flask-xml-rpc/Manifest
new file mode 100644
index 000000000000..41b462626ac0
--- /dev/null
+++ b/dev-python/flask-xml-rpc/Manifest
@@ -0,0 +1 @@
+DIST Flask-XML-RPC-0.1.2.tar.gz 5756 SHA256 4adc7482240a916e8c2205cba38b4bd6e648692d189419686a3116768fa48ab7 SHA512 0e083b70576b0d09a316f8be9a779eeb24723caede172fe51168b2b125553b7916e65012813976d46b03787d1f5c24ad6524267d432a246aaf8b222023481e85 WHIRLPOOL e50373eb0cdc7453d94204fc2f3d6c6eba03233e0c313138cd62d1a6c312463aa6f170228ca7f00697bcb1df0e50e4dd7fc2b1d03c2a227c49687d247e14b71a
diff --git a/dev-python/flask-xml-rpc/flask-xml-rpc-0.1.2-r1.ebuild b/dev-python/flask-xml-rpc/flask-xml-rpc-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..22db8a3be294
--- /dev/null
+++ b/dev-python/flask-xml-rpc/flask-xml-rpc-0.1.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Flask-XML-RPC"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XML-RPC support for Flask applications"
+HOMEPAGE="http://packages.python.org/Flask-XML-RPC/ http://pypi.python.org/pypi/Flask-XML-RPC"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests || die
+}
diff --git a/dev-python/flask-xml-rpc/metadata.xml b/dev-python/flask-xml-rpc/metadata.xml
new file mode 100644
index 000000000000..e0e8cc3a894d
--- /dev/null
+++ b/dev-python/flask-xml-rpc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Flask-XML-RPC</remote-id>
+ </upstream>
+</pkgmetadata>