summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViktar Patotski (aka xp-vit) <xp.vit.blr@gmail.com>2020-05-02 16:08:30 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-03 08:35:40 +0200
commit4bf0c56df14ffa10dc6583b55864428720272e65 (patch)
treec0dc99a92d80cb2df5e771dddf2f667661b30ff8 /dev-python/flask-babelex
parentx11-misc/xdg-utils: Make a 1.1.3_p20200220 snap (diff)
downloadgentoo-4bf0c56df14ffa10dc6583b55864428720272e65.tar.gz
gentoo-4bf0c56df14ffa10dc6583b55864428720272e65.tar.bz2
gentoo-4bf0c56df14ffa10dc6583b55864428720272e65.zip
dev-python/flask-babelex: version bump to 0.9.4
Bump to 0.9.4. This also fixes compatobility with dev-python/werkzeug-1.0.0+. Closes: https://bugs.gentoo.org/720466 Closes: https://bugs.gentoo.org/708714 Signed-off-by: Viktar Patotski <xp.vit.blr@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15611 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-babelex')
-rw-r--r--dev-python/flask-babelex/Manifest1
-rw-r--r--dev-python/flask-babelex/flask-babelex-0.9.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/flask-babelex/Manifest b/dev-python/flask-babelex/Manifest
index 6d7caa59ea1e..9b44bb13e26e 100644
--- a/dev-python/flask-babelex/Manifest
+++ b/dev-python/flask-babelex/Manifest
@@ -1 +1,2 @@
DIST Flask-BabelEx-0.9.3.tar.gz 41040 BLAKE2B 010f8a7be2d59db143010456673a34e2a42f8978cf000d844f11d27969f120c0768038271b8c62b4f6965a3a60f9c845c4027daf26459fce1489482cad0f8856 SHA512 c759f990c4c96dab7cf2fbe83c1ac6dde4606adfd2f5d03ed293578bec621170be319b71fc3e38c1910d2edaba3e4394f32ede3754940e315abd917beaf3982c
+DIST Flask-BabelEx-0.9.4.tar.gz 43423 BLAKE2B 9aa6223cd29cd1ce3de0d8c8b771980457fa0ee76b7fd361b9b6d8ae79f521b36096b4d912281b7fe671655ac8c7b04032c68fcc59463c5630af073f264f5815 SHA512 0deec4b481876f4c76cde398157cd2bdc564e9d1076a7accf1720be86b41912466435412ad5f7e5e8b06f17ad5363ea503191b159b30625d067e76a45eaba957
diff --git a/dev-python/flask-babelex/flask-babelex-0.9.4.ebuild b/dev-python/flask-babelex/flask-babelex-0.9.4.ebuild
new file mode 100644
index 000000000000..75210c43206e
--- /dev/null
+++ b/dev-python/flask-babelex/flask-babelex-0.9.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+MY_PN="Flask-BabelEx"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Adds i18n/l10n support to Flask applications"
+HOMEPAGE="https://github.com/mrjoes/flask-babelex https://pypi.org/project/Flask-BabelEx/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1[${PYTHON_USEDEP}]
+ >=dev-python/speaklater-1.2[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.5[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )"
+
+distutils_enable_sphinx docs \
+ dev-python/flask-sphinx-themes
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.3-tests-fix.patch" )
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" tests.py || die "Testing failed with ${EPYTHON}"
+}