summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-22 06:12:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-22 07:53:29 +0200
commitc07023e1aad917682caeffaa2ea06c7bd88c78ed (patch)
tree02fe665fcf7572e448341d109b2a160cd719ab41 /dev-python/fastjsonschema
parentdev-python/ansible-compat: Bump to 4.0.5 (diff)
downloadgentoo-c07023e1aad917682caeffaa2ea06c7bd88c78ed.tar.gz
gentoo-c07023e1aad917682caeffaa2ea06c7bd88c78ed.tar.bz2
gentoo-c07023e1aad917682caeffaa2ea06c7bd88c78ed.zip
dev-python/fastjsonschema: Bump to 2.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fastjsonschema')
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.17.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 1d41f24ea5cf..0052e0e8a78f 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
+DIST fastjsonschema-2.17.0.tar.gz 370871 BLAKE2B 9d5f16dba7c8519d5bb4853188ba982e06b39a2c1689963ef3aec39e2d48cccbba7ba9ab93cf1b54a06f4e8107917acdb31b076f44b7baf9e9a432256a2f2844 SHA512 ee19945c489b9d4fd23a0a348ec13f321705e93e1367c04003c41b86abd92da2ac73ca6dcd46a9eba0b8b72e8ba899a00939d8a56059fd04eac4300e20589551
DIST python-fastjsonschema-2.16.3.gh.tar.gz 392011 BLAKE2B 04990592a2bf6e1309bf725361ef7c2e253c4765c5b9d60805c5e6189f14885a3b0bae98945c2fe228adc335ca8c8c0a243b283b24fa447238d6415d439288e2 SHA512 2e26f31f9c6966e77f70b8ca584e672d554219b6bbb4811e3ac8dff1c693b2638ef08b8b9011e0db6f739be02e2f41a35d15bcfc42a9cb06ddb4521e51f37d8a
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.17.0.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.17.0.ebuild
new file mode 100644
index 000000000000..9a16ce7b1b94
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.17.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/benchmarks
+)
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # stray directory?
+ # https://github.com/horejsek/python-fastjsonschema/issues/173
+ rm -r tests/examples/lengths || die
+}