summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-28 21:01:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-28 21:01:14 +0100
commitfbbd148b6cb3ba7cfbf93ea1a5c53a4341f60c9a (patch)
tree127231980497b8e8b0106473f121347c646bee45 /dev-python/eyeD3/eyeD3-0.9.6.ebuild
parentnet-misc/youtube-dl: Bump to 2020.12.29 (diff)
downloadgentoo-fbbd148b6cb3ba7cfbf93ea1a5c53a4341f60c9a.tar.gz
gentoo-fbbd148b6cb3ba7cfbf93ea1a5c53a4341f60c9a.tar.bz2
gentoo-fbbd148b6cb3ba7cfbf93ea1a5c53a4341f60c9a.zip
dev-python/eyeD3: Bump to 0.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/eyeD3/eyeD3-0.9.6.ebuild')
-rw-r--r--dev-python/eyeD3/eyeD3-0.9.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/eyeD3/eyeD3-0.9.6.ebuild b/dev-python/eyeD3/eyeD3-0.9.6.ebuild
new file mode 100644
index 000000000000..79cdf41bddba
--- /dev/null
+++ b/dev-python/eyeD3/eyeD3-0.9.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for manipulating ID3 (v1 + v2) tags in Python"
+HOMEPAGE="https://eyed3.nicfit.net/"
+SRC_URI="https://github.com/nicfit/eyeD3/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://eyed3.nicfit.net/releases/eyeD3-test-data.tgz )"
+
+LICENSE="GPL-2"
+SLOT="0.7"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/deprecation[${PYTHON_USEDEP}]
+ dev-python/filetype[${PYTHON_USEDEP}]"
+# note: most of the deps are optional runtime deps / plugin deps
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pylast[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # requires unpackaged factory-boy, doesn't seem to relevant
+ # to anything but eyeD3 usage with factory-boy
+ rm test/test_factory.py || die
+ # requires unpackaged grako
+ rm test/test_display_plugin.py || die
+
+ if use test; then
+ mv "${WORKDIR}"/eyeD3-test-data test/data || die
+ fi
+
+ distutils-r1_src_prepare
+}