summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-05 18:39:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-05 18:40:09 +0100
commitfc5945bdba2a5547b5bd8827342eabab8ffcacc3 (patch)
tree9c308c3e29b4750c54a922869b4650d15dd04a98 /dev-python/discid
parentdev-python/python-discid: Prepare for rename (diff)
downloadgentoo-fc5945bdba2a5547b5bd8827342eabab8ffcacc3.tar.gz
gentoo-fc5945bdba2a5547b5bd8827342eabab8ffcacc3.tar.bz2
gentoo-fc5945bdba2a5547b5bd8827342eabab8ffcacc3.zip
Rename dev-python/{python-discid → discid}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/discid')
-rw-r--r--dev-python/discid/Manifest1
-rw-r--r--dev-python/discid/discid-1.2.0-r1.ebuild40
-rw-r--r--dev-python/discid/metadata.xml12
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/discid/Manifest b/dev-python/discid/Manifest
new file mode 100644
index 000000000000..7bbf1b7d40f7
--- /dev/null
+++ b/dev-python/discid/Manifest
@@ -0,0 +1 @@
+DIST python-discid-1.2.0.gh.tar.gz 30756 BLAKE2B 616613de23b66adfc92227a9f36b710649f2a419ffd83443766ebcf1dbfaf528b7d933011bcbdcd19f5092726b81e40d905a62a64262a528dfad89e561210992 SHA512 239cb608508e94109aa9b8b582bc3de1fb9408b508d56698d7f17ec9ebb0d37c1fb76557d98b6d194c1532e3047efcde3adc5d6e9634bc87533d331423a7f19f
diff --git a/dev-python/discid/discid-1.2.0-r1.ebuild b/dev-python/discid/discid-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..540422f5c129
--- /dev/null
+++ b/dev-python/discid/discid-1.2.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-discid-${PV}
+DESCRIPTION="Python bindings for libdiscid"
+HOMEPAGE="
+ https://python-discid.readthedocs.io/en/latest/
+ https://github.com/JonnyJD/python-discid/
+ https://pypi.org/project/discid/
+"
+SRC_URI="
+ https://github.com/JonnyJD/python-discid/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc x86"
+
+DEPEND="
+ >=media-libs/libdiscid-0.2.2
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_sphinx doc
+
+python_test() {
+ "${EPYTHON}" -m unittest -v test_discid.TestModule{Private,} ||
+ die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/discid/metadata.xml b/dev-python/discid/metadata.xml
new file mode 100644
index 000000000000..b7e9b9d92f87
--- /dev/null
+++ b/dev-python/discid/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">JonnyJD/python-discid</remote-id>
+ <remote-id type="pypi">discid</remote-id>
+ </upstream>
+</pkgmetadata>