summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-23 04:20:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-23 04:37:07 +0100
commit5ca37bcc1a3520fbbfd5d46e0c26bd3ff1c8dcf3 (patch)
tree5357303db1fa1cd1315f7dfee651eb5fb0376325 /dev-python/debtcollector
parentdev-python/trove-classifiers: Bump to 2024.2.22 (diff)
downloadgentoo-5ca37bcc1a3520fbbfd5d46e0c26bd3ff1c8dcf3.tar.gz
gentoo-5ca37bcc1a3520fbbfd5d46e0c26bd3ff1c8dcf3.tar.bz2
gentoo-5ca37bcc1a3520fbbfd5d46e0c26bd3ff1c8dcf3.zip
dev-python/debtcollector: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/debtcollector')
-rw-r--r--dev-python/debtcollector/Manifest1
-rw-r--r--dev-python/debtcollector/debtcollector-3.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/debtcollector/Manifest b/dev-python/debtcollector/Manifest
index dc03bf6280ab..eab9f7bd1eb6 100644
--- a/dev-python/debtcollector/Manifest
+++ b/dev-python/debtcollector/Manifest
@@ -1 +1,2 @@
DIST debtcollector-2.5.0.tar.gz 31334 BLAKE2B 1f06725ead19e36e6feda1c8666403e536d5f39f775d9a9929a06ea053be41e64575a4e4d28b3a0032610cdd7f68f35bf54ff2445543c4b8ec667732e1a8d5ea SHA512 3f1378c52994a0320b8abd997a1b240496f6f12d29e8b08612bb97c7c8d2993b23224be62cbe4eaa556dcd5a3c7a4a8f8ea4873688e1aad2f26bb5ba522c1d6a
+DIST debtcollector-3.0.0.tar.gz 31322 BLAKE2B 496ca931267a0bb93b009f69c5488eb59cc0a2c1fbf437c66023e5074c3623f2d726109c2ab73462e4a81160f5c089b81045d66cd3370ab69500ce97d1568477 SHA512 92072dbe27b09fe9bccf2fe7d27f29742bfa50d19dab60ce5e4b442833aff3dda6f0dd9f72b7a2d3ce580a78d1480e03353d8f9b0e43b59575b979a20945ee26
diff --git a/dev-python/debtcollector/debtcollector-3.0.0.ebuild b/dev-python/debtcollector/debtcollector-3.0.0.ebuild
new file mode 100644
index 000000000000..e778e9427b2d
--- /dev/null
+++ b/dev-python/debtcollector/debtcollector-3.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python deprecation patterns and strategies that collect technical debt"
+HOMEPAGE="
+ https://opendev.org/openstack/debtcollector/
+ https://github.com/openstack/debtcollector/
+ https://pypi.org/project/debtcollector/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest