summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-23 06:15:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-23 07:17:59 +0100
commitf4b83e0ecc48d815531b30857954dff513101ad8 (patch)
tree0d4debf9e958010d34c2490924891a1e01f1df8a /dev-python/coverage
parentapp-admin/awscli: Bump to 1.27.77 (diff)
downloadgentoo-f4b83e0ecc48d815531b30857954dff513101ad8.tar.gz
gentoo-f4b83e0ecc48d815531b30857954dff513101ad8.tar.bz2
gentoo-f4b83e0ecc48d815531b30857954dff513101ad8.zip
dev-python/coverage: Bump to 7.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest1
-rw-r--r--dev-python/coverage/coverage-7.2.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 8f2b198a3039..f1ed3d0513de 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,2 +1,3 @@
DIST coverage-7.0.5.tar.gz 796171 BLAKE2B 87ecffd87c2465607bf1fd330296e84e174953d7696ee0ef3046f6555f54634cfc643ada2a03971685021a5cf59191d75a0bddbc83f736e11a2516c684b0f0d9 SHA512 d199d710cdfac5c6cde79224b4a27d6b88a0e0c504eff7ad5700e9fb1f5cc8e1e9359dcc12f6c447a7ee6cd680feeb89f70ad68574a739c55a6d09b22017df06
DIST coverage-7.1.0.tar.gz 809785 BLAKE2B 3720aee79ecfdd6aa652b5198bad4d6b5827a85f1d58986eec51bab1e72800dac28eb0ebbeb15d547ef03694ca1397bec47c37a9233dc34b2d3d2a6a22a48274 SHA512 80920b337391e47f1e631ba8a892792b6d2c72e753ddf403222c6ad527637699889f29cfee40721949e5eeb6e7977f319635c44d79f58e7e19676d1165dfdde2
+DIST coverage-7.2.0.tar.gz 812120 BLAKE2B 17851996635a1621643e64025ba43f11d7e844fb8757c5bfd6794dbff85cf2c218dc61119c8604f19f951c83264eb13f9c8f0cf7f070f6b213603b25b756a59c SHA512 a913c257702a77b115b6519c0feaf9336973330c9264cb376453555c30f305db2b924d5dd8ff7b58bb89d9f1765b069512929d1ccc9c1c234bdd08d6fc82213b
diff --git a/dev-python/coverage/coverage-7.2.0.ebuild b/dev-python/coverage/coverage-7.2.0.ebuild
new file mode 100644
index 000000000000..b83e4bdd6609
--- /dev/null
+++ b/dev-python/coverage/coverage-7.2.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="
+ https://coverage.readthedocs.io/en/latest/
+ https://github.com/nedbat/coveragepy/
+ https://pypi.org/project/coverage/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/^addopts/s:-q -n auto::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+test_tracer() {
+ local -x COVERAGE_TEST_TRACER=${1}
+ einfo " Testing with the ${COVERAGE_TEST_TRACER} tracer ..."
+ epytest tests
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # pip these days insists on fetching build deps from Internet
+ tests/test_venv.py
+ )
+
+ "${EPYTHON}" igor.py zip_mods || die
+
+ local -x COVERAGE_TESTING=True
+ # TODO: figure out why they can't be imported inside test env
+ local -x COVERAGE_NO_CONTRACTS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=_hypothesis_pytestplugin,flaky.flaky_pytest_plugin,xdist.plugin
+
+ local prev_opt=$(shopt -p nullglob)
+ shopt -s nullglob
+ local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
+ ${prev_opt}
+
+ if [[ -n ${c_ext} ]]; then
+ cp "${c_ext}" \
+ coverage/ || die
+ test_tracer c
+ rm coverage/*.so || die
+ else
+ test_tracer py
+ fi
+}