summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-10 13:52:50 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-10 13:52:50 +0100
commit2a4c125ae660aa46430946351acb0c0d9ca857e8 (patch)
tree64e7893cb1d803032ae22903809ec1f832befe63 /dev-python/couchdb-python/couchdb-python-1.1.ebuild
parentsci-geosciences/mapnik-world-boundaries: Remove last-rited pkg (diff)
downloadgentoo-2a4c125ae660aa46430946351acb0c0d9ca857e8.tar.gz
gentoo-2a4c125ae660aa46430946351acb0c0d9ca857e8.tar.bz2
gentoo-2a4c125ae660aa46430946351acb0c0d9ca857e8.zip
dev-python/couchdb-python: Remove last-rited pkg
Closes: https://bugs.gentoo.org/748063 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/couchdb-python/couchdb-python-1.1.ebuild')
-rw-r--r--dev-python/couchdb-python/couchdb-python-1.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/couchdb-python/couchdb-python-1.1.ebuild b/dev-python/couchdb-python/couchdb-python-1.1.ebuild
deleted file mode 100644
index 22089250d21a..000000000000
--- a/dev-python/couchdb-python/couchdb-python-1.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="CouchDB"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python library for working with CouchDB"
-HOMEPAGE="https://github.com/djc/couchdb-python https://pypi.org/project/CouchDB/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}
-
-# Tests require connectivity to a couchdb server.
-# Re-enable when the ebuild is capable of starting a local couchdb
-# instance.
-RESTRICT=test
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- distutils-r1_python_install_all
-}