summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-19 08:08:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-19 10:42:48 +0100
commitf51410fe23786bde4cefe1b6bd6f4776060d5844 (patch)
tree38a1baf1e021538e7cf40b9d7fab383ba7ccc97e /dev-python/cliff
parentdev-python/identify: Bump to 2.5.9 (diff)
downloadgentoo-f51410fe23786bde4cefe1b6bd6f4776060d5844.tar.gz
gentoo-f51410fe23786bde4cefe1b6bd6f4776060d5844.tar.bz2
gentoo-f51410fe23786bde4cefe1b6bd6f4776060d5844.zip
dev-python/cliff: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-4.1.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 4668b5ae75d0..7ea7f8da2bd6 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
DIST cliff-4.0.0.tar.gz 82758 BLAKE2B 47bc6d15426208c35582e852b7c52620b4fde292f2cc8bba1ba18ca01ef0cb3eda442ec406d2da7abb525fd659e055d08fa64c390a2274a8eea714489435957d SHA512 2886c2697c81c640cd3909c7e00fa50b0e39ed3824c8594d45af30e876cbfa73161be35c668c9bf964a5716bbb2b6e0cfef69526346e1d35156b5dbc24a7dc06
+DIST cliff-4.1.0.tar.gz 82892 BLAKE2B 2d4da66ca6ba86c9f0f33fa36f637363a25ac0ea5c7a1561a4e682769e7ecc97525fca93fde0597062e8f23c4d3334fbf08a305f1c5bb15918e5752a45992d0e SHA512 4bab3404207d21cf8111a6dc1a0ece2c8da5d3bf5ee261b351b7b7ade73f162c4cea225be6fac7444ae95de70d3079e727086fd954fbf56b6d61fb1c7eb4c44a
diff --git a/dev-python/cliff/cliff-4.1.0.ebuild b/dev-python/cliff/cliff-4.1.0.ebuild
new file mode 100644
index 000000000000..8bf1ddb73cae
--- /dev/null
+++ b/dev-python/cliff/cliff-4.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.11.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest