summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-18 17:45:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-18 17:45:57 +0200
commitc8693b5a626f474e1461650e2fc7206d4eb4d417 (patch)
tree58f14a5a469c74067c3a9c1cee53524b90efdbaf /dev-python/cchardet
parentdev-python/argcomplete: Remove old (diff)
downloadgentoo-c8693b5a626f474e1461650e2fc7206d4eb4d417.tar.gz
gentoo-c8693b5a626f474e1461650e2fc7206d4eb4d417.tar.bz2
gentoo-c8693b5a626f474e1461650e2fc7206d4eb4d417.zip
dev-python/cchardet: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cchardet')
-rw-r--r--dev-python/cchardet/Manifest1
-rw-r--r--dev-python/cchardet/cchardet-2.1.7-r1.ebuild31
-rw-r--r--dev-python/cchardet/files/cchardet-2.1.7-pytest.patch120
3 files changed, 0 insertions, 152 deletions
diff --git a/dev-python/cchardet/Manifest b/dev-python/cchardet/Manifest
index 898f05e370b4..a65142331148 100644
--- a/dev-python/cchardet/Manifest
+++ b/dev-python/cchardet/Manifest
@@ -1,2 +1 @@
-DIST cchardet-2.1.7.tar.gz 653617 BLAKE2B 0ca9becac01c67da191290c7de0dc52d5c8e6c2715f660811c8e67d9a06e74ac155a081de81af96ade74ccc4065093fc226f232a26f66236fafe9fc1b48a9c9e SHA512 43e663e30ec079b2a954862de5e8136a2e40f69e300d65eb4ce9d7ffa5d8c496dc7c0937b3306b4096cfad12a1d0617628f8f0115534ab6faf9eb39d2b3935a2
DIST faust-cchardet-2.1.19.tar.gz 678871 BLAKE2B e87389ef602bc5e69ae2037aff1000b9caacfd91a44c5eb8fb2084d4ac33772eb8e480b05109ff83ebfcb2b9a57e215b4bc9cc5558f4f7e1a19b58dd1dfca8b5 SHA512 bd75ddf8b2e9891fe6ecdfd687a6903342a24b93f35a3d9a1b20da9abc77684e73840db73da97689636e3412e33da25b68cfafad114186681d0dec98880ffe95
diff --git a/dev-python/cchardet/cchardet-2.1.7-r1.ebuild b/dev-python/cchardet/cchardet-2.1.7-r1.ebuild
deleted file mode 100644
index 3cb84bf4e1db..000000000000
--- a/dev-python/cchardet/cchardet-2.1.7-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="High speed universal character encoding detector"
-HOMEPAGE="
- https://github.com/PyYoshi/cChardet
- https://pypi.org/project/cchardet/
-"
-
-LICENSE="MPL-1.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- # https://github.com/PyYoshi/cChardet/pull/78
- "${FILESDIR}/${P}-pytest.patch"
-)
-
-distutils_enable_tests pytest
diff --git a/dev-python/cchardet/files/cchardet-2.1.7-pytest.patch b/dev-python/cchardet/files/cchardet-2.1.7-pytest.patch
deleted file mode 100644
index 11f38579c184..000000000000
--- a/dev-python/cchardet/files/cchardet-2.1.7-pytest.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-https://github.com/PyYoshi/cChardet/pull/78
-
-From: q0w <43147888+q0w@users.noreply.github.com>
-Date: Wed, 17 Nov 2021 14:50:41 +0300
-Subject: [PATCH 02/13] Use pytest
-
---- /dev/null
-+++ b/src/tests/cchardet_test.py
-@@ -0,0 +1,111 @@
-+import glob
-+import os
-+
-+import cchardet
-+
-+SKIP_LIST = [
-+ 'src/tests/testdata/ja/utf-16le.txt',
-+ 'src/tests/testdata/ja/utf-16be.txt',
-+ 'src/tests/testdata/es/iso-8859-15.txt',
-+ 'src/tests/testdata/da/iso-8859-1.txt',
-+ 'src/tests/testdata/he/iso-8859-8.txt'
-+]
-+
-+# Python can't decode encoding
-+SKIP_LIST_02 = [
-+ 'src/tests/testdata/vi/viscii.txt',
-+ 'src/tests/testdata/zh/euc-tw.txt'
-+]
-+SKIP_LIST_02.extend(SKIP_LIST)
-+
-+
-+def test_ascii():
-+ detected_encoding = cchardet.detect(b'abcdefghijklmnopqrstuvwxyz')
-+ assert 'ascii' == detected_encoding['encoding'].lower()
-+
-+
-+def test_detect():
-+ testfiles = glob.glob('src/tests/testdata/*/*.txt')
-+ for testfile in testfiles:
-+ if testfile.replace("\\", "/") in SKIP_LIST:
-+ continue
-+
-+ base = os.path.basename(testfile)
-+ expected_charset = os.path.splitext(base)[0]
-+ with open(testfile, 'rb') as f:
-+ msg = f.read()
-+ detected_encoding = cchardet.detect(msg)
-+ assert expected_charset.lower() == detected_encoding['encoding'].lower()
-+
-+
-+def test_detector():
-+ detector = cchardet.UniversalDetector()
-+ with open("src/tests/samples/wikipediaJa_One_Thousand_and_One_Nights_SJIS.txt", 'rb') as f:
-+ line = f.readline()
-+ while line:
-+ detector.feed(line)
-+ if detector.done:
-+ break
-+ line = f.readline()
-+ detector.close()
-+ detected_encoding = detector.result
-+ assert "shift_jis" == detected_encoding['encoding'].lower()
-+
-+
-+def test_github_issue_20():
-+ """
-+ https://github.com/PyYoshi/cChardet/issues/20
-+ """
-+ msg = b'\x8f'
-+
-+ cchardet.detect(msg)
-+
-+ detector = cchardet.UniversalDetector()
-+ detector.feed(msg)
-+ detector.close()
-+
-+
-+def test_decode():
-+ testfiles = glob.glob('src/tests/testdata/*/*.txt')
-+ for testfile in testfiles:
-+ if testfile.replace("\\", "/") in SKIP_LIST_02:
-+ continue
-+
-+ base = os.path.basename(testfile)
-+ expected_charset = os.path.splitext(base)[0]
-+ with open(testfile, 'rb') as f:
-+ msg = f.read()
-+ detected_encoding = cchardet.detect(msg)
-+ try:
-+ msg.decode(detected_encoding["encoding"])
-+ except LookupError as e:
-+ print("LookupError: { file=%s, encoding=%s }" % (
-+ testfile, detected_encoding["encoding"]))
-+ raise e
-+
-+
-+def test_utf8_with_bom():
-+ sample = b'\xEF\xBB\xBF'
-+ detected_encoding = cchardet.detect(sample)
-+ assert "utf-8-sig" == detected_encoding['encoding'].lower()
-+
-+
-+def test_null_bytes():
-+ sample = b'ABC\x00\x80\x81'
-+ detected_encoding = cchardet.detect(sample)
-+
-+ assert detected_encoding['encoding'] is None
-+
-+# def test_iso8859_2_csv(self):
-+# testfile = 'tests/samples/iso8859-2.csv'
-+# with open(testfile, 'rb') as f:
-+# msg = f.read()
-+# detected_encoding = cchardet.detect(msg)
-+# eq_(
-+# "iso8859-2",
-+# detected_encoding['encoding'].lower(),
-+# 'Expected %s, but got %s' % (
-+# "iso8859-2",
-+# detected_encoding['encoding'].lower()
-+# )
-+# )