summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-01 08:02:14 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-01 08:45:53 +0100
commit3d6e14e48beba82c161088dcb6dafc2859842c1f (patch)
tree50a1706cafc04c198abaab8fb2ab7158d63b2629 /dev-python/boto3
parentdev-python/botocore: Bump to 1.23.17 (diff)
downloadgentoo-3d6e14e48beba82c161088dcb6dafc2859842c1f.tar.gz
gentoo-3d6e14e48beba82c161088dcb6dafc2859842c1f.tar.bz2
gentoo-3d6e14e48beba82c161088dcb6dafc2859842c1f.zip
dev-python/boto3: Bump to 1.20.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.17.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 9e37c1d9f96d..9213eeaa9bd8 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,4 +1,5 @@
DIST boto3-1.19.12.tar.gz 436654 BLAKE2B f92e756bc9f98105e3126e41cf0d6fab948bbd79f088ee4e0f0f5f319d4a6e542c0702b487404b316f794b304c43f9c26da026257476341971a7ce241538f506 SHA512 e6b20730f35bb422a2f74e978adc0bac77aa18b4e80eab5175dc117cf2762a7d8e53d390c50df24dada6f1d071d78309c69598ffb3f8d93fd45a3d1f772a866f
DIST boto3-1.20.14.tar.gz 449126 BLAKE2B b2ef8a101aaecb5d65a60fcbf7f83e89946181092bb4ad1f4a7abcf8b218c5ce797a47cd9ac3e7fdee85c6457d89b91836729f4019f5ecebf1193d015714ca8a SHA512 ff4e3f2accde84fe71cdcb090775c384700d3cba0d43f46a834b653f6a9493d7cd57be1741f39378cddf315d5f5ce07f4f233c300feb1529c22e99a0817af85c
DIST boto3-1.20.15.tar.gz 449395 BLAKE2B 702a8e1c156b3c4d3f6d5428779bbeb2f917a9977d5b34553ebef684e14dfb680ca1fbd513e285dbf706c8de8e9469f1bbe19655992649a10290dbde4cd5f641 SHA512 2b2b77670df654594adc0047214a4d68f800611a2b8d6f4faeba10a66bd289508eb88f34a436c59eb4bbe65f549baae4a5676054c38b7816f16d8de46a41fe94
+DIST boto3-1.20.17.tar.gz 452876 BLAKE2B ff59e490e5938bea7cdd0ae54f82c33d410b42b9417a16e9890e809cc3540d07711ae2285f354129b178e59d7400b25e2176907354acb12bcfeb5dd5d3bc0111 SHA512 1232f475282666fa6653407bebfd85fee5d681523a94da56adf02616117002d7123e6f55523ef042f89cd5971031192665b84ca5619d26b1795cf597e1060082
DIST boto3-1.20.5.tar.gz 439166 BLAKE2B c140e15e497e6cdf6b4b77bb99e0a0f5ac01d5b5793f8bfb210b52bbc09e39e6fe06a957951375e0795210dc1c3b2a0afd2f498bc88e449d9e6846f2b357f016 SHA512 2823466e4851684253d4ce42a8c34e5cbdad6d04c823040fe2cebdf0cffb14d5d3f40e28d57ebec14533fab04ba74f27c25f078ddb8791b8f52d0424e11b39fc
diff --git a/dev-python/boto3/boto3-1.20.17.ebuild b/dev-python/boto3/boto3-1.20.17.ebuild
new file mode 100644
index 000000000000..a4f6b1d0f3c2
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.17.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}