summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/biplist
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/biplist')
-rw-r--r--dev-python/biplist/Manifest2
-rw-r--r--dev-python/biplist/biplist-0.8.ebuild27
-rw-r--r--dev-python/biplist/biplist-0.9.ebuild29
-rw-r--r--dev-python/biplist/metadata.xml13
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/biplist/Manifest b/dev-python/biplist/Manifest
new file mode 100644
index 000000000000..bc9379d77f2c
--- /dev/null
+++ b/dev-python/biplist/Manifest
@@ -0,0 +1,2 @@
+DIST biplist-0.8.tar.gz 14306 SHA256 d8a9c6dff4d2a45fb3e9f27d19ea63da0a82ed59c758c34f6342badaccf6ea71 SHA512 7b2fe9b0c4080ae690f1d856a0fc7ca3bbabfed81aa4c06509d584041be4802e4e1b004bef83326f518baf1cbc147dc36b0c55e769a6b5c170fee278f7b1d9d8 WHIRLPOOL 024a283e536c6e56275d48232f3b7a134c15169ff853821e4050fb8bddc6381827e526ac107c352bb9d45bc8965b15cb0a9528580340f03efde416a70c0c8c5a
+DIST biplist-0.9.tar.gz 14591 SHA256 b57cadfd26e4754efdf89e9e37de87885f9b5c847b2615688ca04adfaf6ca604 SHA512 d0999f6f4d23a4f4e1eaabb831750cb8d51a452b7896ed85409bb8614ba3e89e1e558688de5f5259a86503a55886887c6364d37a886d2ad5699fd067f0be7230 WHIRLPOOL 5d7a757c151737939a1759817d396a200b52074dc317fc14bb751b54b74fd36fae1f4d01036f5bb39859c6312da4ff5f438b2d0e120b1aa45cffe4c76edfd468
diff --git a/dev-python/biplist/biplist-0.8.ebuild b/dev-python/biplist/biplist-0.8.ebuild
new file mode 100644
index 000000000000..048a32dde080
--- /dev/null
+++ b/dev-python/biplist/biplist-0.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A binary plist parser/generator for Python"
+HOMEPAGE="http://pypi.python.org/pypi/biplist/ https://github.com/wooster/biplist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ ${RDEPEND} )"
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/biplist/biplist-0.9.ebuild b/dev-python/biplist/biplist-0.9.ebuild
new file mode 100644
index 000000000000..d5bd4e69cdc1
--- /dev/null
+++ b/dev-python/biplist/biplist-0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A binary plist parser/generator for Python"
+HOMEPAGE="http://pypi.python.org/pypi/biplist/ https://github.com/wooster/biplist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ ${RDEPEND} )"
+
+python_test() {
+ # This failure still occurs, after 18 momths
+ # https://github.com/wooster/biplist/issues/8
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/biplist/metadata.xml b/dev-python/biplist/metadata.xml
new file mode 100644
index 000000000000..e1a3378cacbc
--- /dev/null
+++ b/dev-python/biplist/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">biplist</remote-id>
+ <remote-id type="github">wooster/biplist</remote-id>
+ </upstream>
+</pkgmetadata>