summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-10-18 15:48:17 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-10-18 15:54:33 -0500
commitf472dd9c698b9f73c120dac03913881054f973ed (patch)
tree8991f21ad2367507b569338d26a4c3cc96e67f0f /dev-python/automaton/automaton-1.12.1.ebuild
parentdev-python/os-brick: 1.15.3 bup (diff)
downloadgentoo-f472dd9c698b9f73c120dac03913881054f973ed.tar.gz
gentoo-f472dd9c698b9f73c120dac03913881054f973ed.tar.bz2
gentoo-f472dd9c698b9f73c120dac03913881054f973ed.zip
dev-python/automaton: 1.12.1 bup
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python/automaton/automaton-1.12.1.ebuild')
-rw-r--r--dev-python/automaton/automaton-1.12.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/automaton/automaton-1.12.1.ebuild b/dev-python/automaton/automaton-1.12.1.ebuild
new file mode 100644
index 000000000000..03fdb23190af
--- /dev/null
+++ b/dev-python/automaton/automaton-1.12.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Friendly state machines for python."
+HOMEPAGE="https://pypi.python.org/pypi/automaton"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8.0[${PYTHON_USEDEP}]"